Logstash 1.3 repository not working?


(Will Appleby) #1

Hi,

I'm fairly new to Logstash/Elasticsearch. Previously I've been using the
downloadable packages for ES and Logstash but seeing the recent blog post (
http://www.elasticsearch.org/blog/apt-and-yum-repositories/) I wanted to
switch to using the repositories to make setup and maintenance easier.

I've got the Elasticsearch one working perfectly but when I try and apt-get
install Logstash 1.3 I'm seeing a 403 Forbidden on the main package
download. Does anyone else get this?

Failed to fetch
http://packages.elasticsearch.org/logstash/1.3/debian/pool/main/l/logstash/logstash_1.3.1-1+debian_all.deb
403 Forbidden

I get the same 403 when accessing the deb package via a browser so I think
something's wrong with the repository setup maybe?

For now I've gone back to 1.2 as it seems to be working, just thought I
would see if anyone else has this problem?

Cheers,
Will.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/26e25410-acc1-49d8-b5bb-7e3e7a3aa245%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Richard Pijnenburg) #2

Hi Will,

My apologies for the confusion.
the 1.3. release has been removed because of bugs in the 1.3.0/1.3.1
releases.
Later today we will be releasing 1.3.2 which has fixes for those bugs.
When that release is done we will update the repo and add the 1.3.2 release
to it.

On Monday, December 23, 2013 10:46:09 AM UTC, Will Appleby wrote:

Hi,

I'm fairly new to Logstash/Elasticsearch. Previously I've been using the
downloadable packages for ES and Logstash but seeing the recent blog post (
http://www.elasticsearch.org/blog/apt-and-yum-repositories/) I wanted to
switch to using the repositories to make setup and maintenance easier.

I've got the Elasticsearch one working perfectly but when I try and
apt-get install Logstash 1.3 I'm seeing a 403 Forbidden on the main package
download. Does anyone else get this?

Failed to fetch
http://packages.elasticsearch.org/logstash/1.3/debian/pool/main/l/logstash/logstash_1.3.1-1+debian_all.deb
http://packages.elasticsearch.org/logstash/1.3/debian/pool/main/l/logstash/logstash_1.3.1-1+debian_all.deb
403 Forbidden

I get the same 403 when accessing the deb package via a browser so I think
something's wrong with the repository setup maybe?

For now I've gone back to 1.2 as it seems to be working, just thought I
would see if anyone else has this problem?

Cheers,
Will.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d62f4b6f-f0f8-4c1e-8b7e-2da757930c37%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Will Appleby) #3

Okay that's fine, explains why it wouldn't work :slight_smile:

1.2 is great for now, just wanted to make sure I was using the latest
version.

Cheers,
Will.

On Monday, December 23, 2013 10:54:49 AM UTC, Richard Pijnenburg wrote:

Hi Will,

My apologies for the confusion.
the 1.3. release has been removed because of bugs in the 1.3.0/1.3.1
releases.
Later today we will be releasing 1.3.2 which has fixes for those bugs.
When that release is done we will update the repo and add the 1.3.2
release to it.

On Monday, December 23, 2013 10:46:09 AM UTC, Will Appleby wrote:

Hi,

I'm fairly new to Logstash/Elasticsearch. Previously I've been using the
downloadable packages for ES and Logstash but seeing the recent blog post (
http://www.elasticsearch.org/blog/apt-and-yum-repositories/) I wanted to
switch to using the repositories to make setup and maintenance easier.

I've got the Elasticsearch one working perfectly but when I try and
apt-get install Logstash 1.3 I'm seeing a 403 Forbidden on the main package
download. Does anyone else get this?

Failed to fetch
http://packages.elasticsearch.org/logstash/1.3/debian/pool/main/l/logstash/logstash_1.3.1-1+debian_all.deb
http://packages.elasticsearch.org/logstash/1.3/debian/pool/main/l/logstash/logstash_1.3.1-1+debian_all.deb
403 Forbidden

I get the same 403 when accessing the deb package via a browser so I
think something's wrong with the repository setup maybe?

For now I've gone back to 1.2 as it seems to be working, just thought I
would see if anyone else has this problem?

Cheers,
Will.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3ccd55bb-1edc-4706-8920-0c09c654b002%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Richard Pijnenburg) #4

Hi,

Just to let you know 1.3.2 has been released and is active in the repo.

Cheers

Richard

On Monday, December 23, 2013 11:01:09 AM UTC, Will Appleby wrote:

Okay that's fine, explains why it wouldn't work :slight_smile:

1.2 is great for now, just wanted to make sure I was using the latest
version.

Cheers,
Will.

On Monday, December 23, 2013 10:54:49 AM UTC, Richard Pijnenburg wrote:

Hi Will,

My apologies for the confusion.
the 1.3. release has been removed because of bugs in the 1.3.0/1.3.1
releases.
Later today we will be releasing 1.3.2 which has fixes for those bugs.
When that release is done we will update the repo and add the 1.3.2
release to it.

On Monday, December 23, 2013 10:46:09 AM UTC, Will Appleby wrote:

Hi,

I'm fairly new to Logstash/Elasticsearch. Previously I've been using the
downloadable packages for ES and Logstash but seeing the recent blog post (
http://www.elasticsearch.org/blog/apt-and-yum-repositories/) I wanted
to switch to using the repositories to make setup and maintenance easier.

I've got the Elasticsearch one working perfectly but when I try and
apt-get install Logstash 1.3 I'm seeing a 403 Forbidden on the main package
download. Does anyone else get this?

Failed to fetch
http://packages.elasticsearch.org/logstash/1.3/debian/pool/main/l/logstash/logstash_1.3.1-1+debian_all.deb
http://packages.elasticsearch.org/logstash/1.3/debian/pool/main/l/logstash/logstash_1.3.1-1+debian_all.deb
403 Forbidden

I get the same 403 when accessing the deb package via a browser so I
think something's wrong with the repository setup maybe?

For now I've gone back to 1.2 as it seems to be working, just thought I
would see if anyone else has this problem?

Cheers,
Will.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7a5fd9d0-4fea-4154-9de2-1f82ff62afda%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Tim Van de Walle) #5

The repo is still broken for me. 1.2 works, but 1.3 is giving a 403 error.

On Friday, December 27, 2013 5:35:00 AM UTC-5, Richard Pijnenburg wrote:

Hi,

Just to let you know 1.3.2 has been released and is active in the repo.

Cheers

Richard

On Monday, December 23, 2013 11:01:09 AM UTC, Will Appleby wrote:

Okay that's fine, explains why it wouldn't work :slight_smile:

1.2 is great for now, just wanted to make sure I was using the latest
version.

Cheers,
Will.

On Monday, December 23, 2013 10:54:49 AM UTC, Richard Pijnenburg wrote:

Hi Will,

My apologies for the confusion.
the 1.3. release has been removed because of bugs in the 1.3.0/1.3.1
releases.
Later today we will be releasing 1.3.2 which has fixes for those bugs.
When that release is done we will update the repo and add the 1.3.2
release to it.

On Monday, December 23, 2013 10:46:09 AM UTC, Will Appleby wrote:

Hi,

I'm fairly new to Logstash/Elasticsearch. Previously I've been using
the downloadable packages for ES and Logstash but seeing the recent blog
post (http://www.elasticsearch.org/blog/apt-and-yum-repositories/) I
wanted to switch to using the repositories to make setup and maintenance
easier.

I've got the Elasticsearch one working perfectly but when I try and
apt-get install Logstash 1.3 I'm seeing a 403 Forbidden on the main package
download. Does anyone else get this?

Failed to fetch
http://packages.elasticsearch.org/logstash/1.3/debian/pool/main/l/logstash/logstash_1.3.1-1+debian_all.deb
http://packages.elasticsearch.org/logstash/1.3/debian/pool/main/l/logstash/logstash_1.3.1-1+debian_all.deb
403 Forbidden

I get the same 403 when accessing the deb package via a browser so I
think something's wrong with the repository setup maybe?

For now I've gone back to 1.2 as it seems to be working, just thought I
would see if anyone else has this problem?

Cheers,
Will.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/07166a23-b2d3-4b6a-b98e-516d9e532c73%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6