Default mapping not working


(afrohlich) #1

I'm trying to set up a default ttl using the default-mapping.json file.
The file is in conf/ and contains the following:
{
"default" : {
"_ttl" : { "enabled" : true, "default" : "7d" }
}
}

When I use curl -XGET "[my ip]:9200/_mapping?pretty=1" new index/type pairs do not have _ttl enabled in their mapping. Is there another setting that I need to change for this to work?

Also, this is using the .deb package and the accompanying init script. This setup worked when I ran it from the zip archive.


(system) #2