Default search timeout doesn't work


it seems like the following settings do not work for elasticsearch 7.17.10:

PUT _cluster/settings
  "persistent": {
    "search.default_search_timeout": "300s",
    "search.low_level_cancellation": "true"

Long running searches are still not cancelled. Is there anything I can configure additionally?


Hi @Ossenfeld

You may need to restart the nodes for the settings to take effect. Another option is to configure the request timeout in the client lib you were using.

I did a rolling restart and the searches are still not being cancelled. Any other ideas?

Any further ideas?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.