Delay to Metribeat system input data into Elasticsearch

Hi Everyone,

I'm monitoring a Linux server with metricbeat, but I noticed a delay for the input of metrics into Elastic (Discover - Kibana). Time is approximately 2 minutes. My configuration is 3 master elastic nodes that respond to a loadbance. In my configuration file I put the LB. And I tried to improve the performance by including 2 to 4 workers, but I didn't see any improvement.
Could you help me to try to solve this delay?

I tested the same configuration on another server e worked well.

follows my module system and metricbeat.yml config:


  # Array of hosts to connect to.
  hosts: "<ip>:9200"
  index: "metric_server_sales"
  worker: 4
  username: "<user>"
  password: "${ES_PWD}"


# Module: system
# Docs:

- module: system
  period: 10s
    - cpu
    - load
    - memory
    - network
    - process
    - process_summary
    - socket_summary
    #- entropy
    #- core
    #- diskio
    #- socket
    #- service
    #- users
    by_cpu: 5      # include top 5 processes by CPU
    by_memory: 5   # include top 5 processes by memory
# Configure the mount point of the host’s filesystem for use in monitoring a host from within a container
#system.hostfs: "/hostfs"

- module: system
  period: 1m
    - filesystem
    - fsstat
  - drop_event.when.regexp:
      system.filesystem.mount_point: '^/(sys|cgroup|proc|dev|etc|host|lib|snap)($|/)'

- module: system
  period: 15m
    - uptime

#- module: system
#  period: 5m
#  metricsets:
#    - raid
#  raid.mount_point: '/'

Best Regards,

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.