Deleted field, result is successfull, but field is still there


I am using Kibana for interacting with my indices. I have a field in _source: '_nisc_AC' which I am trying to delete in the following way:

POST grch38_test__wes__grch38/_update_by_query?conflicts=proceed
    "script" : "ctx._source.remove('nisc_AC')",
    "query" : {
        "exists": { "field": "nisc_AC" }

When I ran it first time, it took several seconds and returned success, no failures. Then I accessed the index again with:

GET /grch38_test__wes__grch38/_search

And the field nisc_AC is there. I tried seeing which versions of the documents I am having but there is no _version field present in my documents. I ran _refresh for the index, but it just mixed up the fields' order without removing them. What is going on? How could I remove key and value from all of the documents?

One thing I can think of would be to add a ?refresh to the request, or just use the refresh API on the index and then see if you can still see the field.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.