Dependency Conflicts while creating Pubsub output plugin


I'm trying to create a custom plugin for publishing events to google pubsub.
Currently I'm using:

Logstash 6.0.0
Trying to use Google::cloud::Pubsub API

I was able to build the gem successfully.
In the gemspec I added dependency for google-cloud-pubsub (latest version),
When I installed the gem, I get this error:

ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "faraday": In snapshot (Gemfile.lock): faraday (= 0.9.2)

In Gemfile: logstash-core (>= 0) java depends on elasticsearch (>= 5.0.4, ~> 5.0) java depends on elasticsearch-transport (= 5.0.4) java depends on faraday (>= 0) java

logstash-output-pubsub (= 0.2.0) java depends on
google-cloud-pubsub (< 0.28.1, ~> 0.27.0) java depends on
google-cloud-core (~> 1.0) java depends on
google-cloud-env (~> 1.0) java depends on
faraday (~> 0.11) java

Running bundle update will rebuild your snapshot from scratch, using only the gems in your Gemfile, which may resolve the conflict.

and when I look on the Gemfile.jruby-2.3.lock I see specific line for faraday (0.9.2).

Is there a way to update the farday version in the Gemfile?
I tried bundle update but I got a different error message...


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.