Logstash-input-google_pubsub install (version conflict) on logstash 5.2


(Mostafa Marji) #1

Validating logstash-input-google_pubsub
Installing logstash-input-google_pubsub
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core":
In snapshot (Gemfile.lock):
logstash-core (= 5.2.0)

In Gemfile:
logstash-core-plugin-api (>= 0) java depends on
logstash-core (= 5.2.0) java

logstash-input-google_pubsub (>= 0) java depends on
  logstash-core (< 3.0.0, >= 2.0.0) java

logstash-core (>= 0) java

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.