5.4 logstash-input-websocket


(Tim) #1

Reported this on the github repo but it doesn't seem to have any traction yet.

Trying to install logstash-input-websocket and am getting the dreaded java error:

root@enb:~# /usr/share/logstash/bin/logstash-plugin install logstash-input-websocket

....
....

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
Bundler could not find compatible versions for gem "logstash-core":
  In snapshot (Gemfile.lock):
    logstash-core (= 5.4.0)

  In Gemfile:
    logstash-core-plugin-api (>= 0) java depends on
      logstash-core (= 5.4.0) java

    x-pack (= 5.4.0) java depends on
      logstash-core (>= 0) java

    logstash-input-websocket (>= 0) java depends on
      logstash-core (< 2.0.0, >= 1.4.0) java

    x-pack (= 5.4.0) java depends on
      logstash-core (>= 0) java

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
Bundler could not find compatible versions for gem "logstash":
  In Gemfile:
    logstash-input-websocket (>= 0) java depends on
      logstash (< 2.0.0, >= 1.4.0) java
Could not find gem 'logstash (< 2.0.0, >= 1.4.0) java', which is required by gem 'logstash-input-websocket (>= 0) java', in any of the sources.

Any ideas for a fix? Really need this asap.


(Magnus B├Ąck) #2

I've summarized the situation in the issue below.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.