Logstash-filter-cipher won't install (for me) against logstash 5.0.2


(Kallax) #1

apologies in advance if this is not the correct forum for this question...

i'm unable to install logstash-filter-cipher. when i try, i get the below error. i'm running centos7. any help appreciated

$ ./logstash --version
logstash 5.0.2

$ ./logstash-plugin install logstash-filter-cipher
Validating logstash-filter-cipher
Installing logstash-filter-cipher
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core-plugin-api":
In snapshot (Gemfile.lock):
logstash-core-plugin-api (= 2.1.16)

In Gemfile:
logstash-devutils (~> 1.1) java depends on
logstash-core-plugin-api (~> 2.0) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

..... (repeated many times)

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-filter-cipher (>= 0) java depends on
  logstash-core-plugin-api (~> 1.0) java

logstash-core-plugin-api (>= 0) java

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
Bundler could not find compatible versions for gem "logstash-core":
In snapshot (Gemfile.lock):
logstash-core (= 5.0.2)

In Gemfile:
logstash-core-plugin-api (>= 0) java depends on
logstash-core (= 5.0.2) java

logstash-filter-cipher (>= 0) java depends on
  logstash-core (< 2.0.0, >= 1.4.0) java

logstash-core (>= 0) java

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
Bundler could not find compatible versions for gem "logstash":
In Gemfile:
logstash-filter-cipher (>= 0) java depends on
logstash (< 2.0.0, >= 1.4.0) java
Could not find gem 'logstash (< 2.0.0, >= 1.4.0) java', which is required by gem 'logstash-filter-cipher (>= 0) java', in any of the sources.


(Magnus B├Ąck) #2

The cipher filter isn't Logstash 5.0 compatible yet.


(Kallax) #3

thanks for the response, magnus! (i now see the support matrix.)

i need to decrypt fields from my logs on-the-fly. i'm wondering if anyone knows of an alternative to using the cipher plugin? write a custom plugin?

i guess the work-around is probably to install an older version of logstash and the cipher plugin until 5.x support is ready.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.