Logstash-filter-yaml seems to depend on old logstash-core

(John Dickinson) #1

$ sudo -u logstash ./bin/logstash-plugin install logstash-filter-yaml
Validating logstash-filter-yaml
Installing logstash-filter-yaml
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core":
In snapshot (Gemfile.lock):
logstash-core (= 5.5.2)

In Gemfile:
logstash-core-plugin-api (>= 0) java depends on
logstash-core (= 5.5.2) java

logstash-filter-yaml (>= 0) java depends on
  logstash-core (< 2.0.0, >= 1.4.0) java

logstash-core (>= 0) java

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.

(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.