Deploying behind NAT and Firewall

I am not sure if this is the right place for this topic, so please move it if there is a better one.

My question is how Elasticsearch shall be deployed when behind NAT and Firewall? I created basic setup of Elasticsearch and able to access from other addresses in subnet, however I was unable to access it from the outside world. Tried to turn off ufw, set port forward - nothing helped.

Thank you kindly.

Best regards

You normally use HTTP to talk to Elasticsearch; by default this uses TCP port 9200 but you can change the port number with the http.port setting. This works just fine behind a properly configured NAT device and/or firewall as long as it is set up to allow an incoming connection to end up at the right port to talk to Elasticsearch.

It sounds like your issue is with the configuration of your network. You have not given much detail in your question so it's hard to guess what might be wrong there. Perhaps you will receive more help if you share some more details of your setup (e.g. a description of your network, a copy of elasticsearch.yml, your NAT/firewall configuration, the kinds of error message that you're seeing, etc.).

1 Like

Thank you! After you confirmed this setup should work, I did some trial-error testing and figure out that trouble is in my router: I just moved rule to another place in form and it worked?! Guess its poor firmware from my ISP.

Best regards and sorry for the disturbance!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.