[dev] building elasticsearch - maven issues

Dear contributors (if you are elasticsearch user, you can skip this email),

A commit was push yesterday which changes the names of the maven repositories in the elasticsearch pom file. When you sync to the latest on the master branch you may find that your maven build errors with the following:

[ERROR] Failed to execute goal on project elasticsearch: Could not resolve dependencies for project org.elasticsearch:elasticsearch:jar:2.0.0-SNAPSHOT: Failed to collect dependencies at org.apache.lucene:lucene-test-framework:jar:5.1.0-snapshot-1657571: Failed to read artifact descriptor for org.apache.lucene:lucene-test-framework:jar:5.1.0-snapshot-1657571: Could not transfer artifact org.apache.lucene:lucene-test-framework:pom:5.1.0-snapshot-1657571 from/to lucene-snapshots (https://download.elasticsearch.org/lucenesnapshots/1657571 https://download.elasticsearch.org/lucenesnapshots/1657571): Access denied to: https://download.elasticsearch.org/lucenesnapshots/1657571/org/apache/lucene/lucene-test-framework/5.. https://download.elasticsearch.org/lucenesnapshots/1657571/org/apache/lucene/lucene-test-framework/5..., ReasonPhrase: Forbidden. -> [Help 1]

This is caused by this commit https://github.com/elasticsearch/elasticsearch/commit/3c2414128c6940b2b08ba2628190b1dec8aaa000 which basically tries to solve a Maven issue (MNG-5185 https://jira.codehaus.org/browse/MNG-5185) you can hit if you try to build also plugins.

If you have trouble to compile elasticsearch or a plugin using mvn compile and hit a Access denied to: [URL_HERE], ReasonPhrase: Forbidden. -> [Help 1], you can remove related maven files:

find ~/.m2/repository -name _remote.repositories -exec rm -v {} ;
find ~/.m2/repository -name _maven.repositories -exec rm -v {} ;

Another option is to tell Maven not using those files with --llr:

mvn compile --llr
Note that the later is only a temporary fix.

I hope this will help.

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/C55FCCE3-2291-4684-9CED-F86F7A885D72%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.