Dev Tools Console Error

Hello there,
I'm using Kibana 5.4.0 where Kibana is operating behind a web-server and is using x-pack security.
I've created some visualizations and dashboards.
When I click on DevTools->Console and execute say:
GET /_cat/indices

I get the following response:
"statusCode": 400,
"error": "Bad Request",
"message": "child "method" fails because ["method" is required]",
"validation": {
"source": "query",
"keys": [

If I execute the same request from terminal against elastic-search:
[tango@iel-dev-tfsr-vm2 10:50:14 john]$ curl -XGET -u elastic 'localhost:9200/_cat/indices?v&pretty'
Enter host password for user 'elastic':
health status index uuid pri rep docs.count docs.deleted store.size
yellow open .reporting-2017.06.09.00 B8uo8m6CTMSIyKtnxvDgLw 5 1 1 0 40kb 40kb
yellow open .watcher-history-3-2017.06.06 4eJkH6Q_Tbiu7OH4OoZalg 1 1 3470 0 2.5mb 2.5mb
yellow open .monitoring-es-2-2017.06.08 4Mt3DuniQ1uN9_UmT2PwKQ 1 1 306891 1536 153.4mb 153.4mb
yellow open .watcher-history-3-2017.06.07 zl7YCpClQwqrFrGURouRDA 1 1 7140 0 5.3mb 5.3mb
yellow open .monitoring-kibana-2-2017.06.08 y2-7P7aOQ8mvvj2dWfVbog 1 1 8324 0 1.9mb 1.9mb
yellow open .reporting-2017.06.08.14 u4uteyLVTKWOZXupzbGQcQ 5 1 4 0 206.3kb 206.3kb
yellow open .monitoring-data-2 7qXh_SmgSXKnlMbcpeesXw 1 1 3 0 859.8kb 859.8kb
yellow open irldf-campaign_manager_stats-2017.06.12 CT8yXK30TBifCLuWVtuGuQ 8 1 10 0 66.8kb 66.8kb

The logged in user has roles, kibana_user, reporting_user and irldf_user, where the last role is a custom role for accessing the elastic-search data in irldf-campaign_manager_stats* indices.

Any guidance on how to trouble-shoot this would be much appreciated.

It sounds like your kibana front-end and back-end might be out of sync. Have you refreshed the page in a while? Can you try using a new tab/private browsing?

Thanks for responding Spencer.
I tried restarting kibana and opening in new tab and opening incongito mode, but I get the same result.
One thing that might have caused problems though, is that I'm testing on target environment that was low on disk space and it reached 100% utilization a couple of times. At that point, I removed some audit logs to make room and restarted both elastic-search and kibana.
Also, in my curl statement above I specifically making request as elastic user. Is it possible that the console is returning the error due to the fact that the logged in user is missing a role in needs?

I'm having the same issue, but I am using ELK version 5.3. Was there a fix?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.