Disable APM Privileges Dialog

How can I turn off the Dialog with the PermissionsWarning which says:

" Missing permissions to access APM

Your user doesn't have access to all APM indices. You can still use the APM app but some data may be missing. You must be granted access to the following indices:"

Since the index Settings for apm is not per space i have to use something like apm-*

The real indizes and permissions is based on apm-app1-* and apm-app2-*, ...
So it's ok when a user does not sees all

Hi @FlorianBeck, thanks for your message.

The only workaround to avoid showing this page is to change the index name on the APM settings page. But as you mentioned it's not per space (we've got an issue open to fix it https://github.com/elastic/kibana/issues/49647).
But we decided to remove the Missing permission page on v7.9 https://github.com/elastic/kibana/issues/71520#issuecomment-659299841.

1 Like

Thank you for clarification. Ver supportive! Awesome!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.