Disable APM Remote configuration Errors

Kibana version: 7.8.1

Elasticsearch version: 7.8.1

APM Server version: 7.8.1

Is there anything special in your setup?
enabled: false
enabled: false
overwrite: false
We use the template that is generated by apm-server export template

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):
We get about 36k error messages per day that say: "forbidden request: Agent remote configuration is disabled. Configure the apm-server.kibana section in apm-server.yml to enable it. If you are using a RUM agent, you also need to configure the apm-server.rum section. If you are not using remote configuration, you can safely ignore this error."

I know that I can ignore those, but its cluttering the log and disk.
Is there any way to suppress this message or to tell the APM-Agent not to try accessing remot configuration?

Hi @Loran_Fininure,

Thanks for reaching out.

The central config is disabled by default in the RUM agent, you can see the configuration here.

However, that message can be logged if one of the backend agents requests the configuration. Backend agents have central config enabled by default but there's a configuration to disable it. Please see this guide to find the right configuration for each agent.

Hope this helps,

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.