Disable geoip

I am trying to deploy Elasticsearch 7.17.1 on a server behind a very strict firewall (basically no Internet access is allowed.
The deployment is via a bat file (not Docker).
The Elasticsearch.yml is virtually all comments, but having got the issue below I added
ingest.geoip.downloader.enabled: false

But even with is it still tries to get to the Internet - as this log shows:
(The may be other issues - but I am trying to sort this one first :slight_smile:

[2022-04-01T09:35:04,493][INFO ][o.e.i.g.GeoIpDownloader ] [xxxxxx] updating geoip databases
[2022-04-01T09:35:04,493][INFO ][o.e.i.g.GeoIpDownloader ] [xxxxxx] fetching geoip databases overview from [https://geoip.elastic.co/v1/database?elastic_geoip_service_tos=agree]
[2022-04-01T09:35:04,524][ERROR][o.e.i.g.GeoIpDownloader ] [xxxxxx] exception during geoip databases update
java.net.UnknownHostException: geoip.elastic.co
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184) ~[?:1.8.0_242]


PUT /_cluster/settings
  "persistent" : {
    "ingest.geoip.downloader.enabled" : false

See GeoIP processor | Elasticsearch Guide [8.1] | Elastic

Thank you. However I was unable to implement your solution as a knock on from my issue was that Kibana would not start. So I was guessing that my issue was causing this. But another avenue I pursued was to update Chrome - which was woefully out of date. This was not easy as I had to plead with our firewall guys to let the update through. Once this was done, Kibana started and it looks as though the GeoIp thing was not an issue after all.
But THANK YOU anyway - useful gen for another time :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.