Disabling date detection [Hive-Elasticsearch]


(shankarramshivram) #1

Hi ,

My write to es from mapr fails because of the automatic date detection
being enabled . Is there a way to disable date detection from the external
hive table properties. ?
Request to please guide me regarding this.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ed7e40b0-b896-4633-88fc-efdf2bead65a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Costin Leau) #2

Not sure what you mean by failing but you can control the index (and thus disable date detection and many others) by
creating the index before hand with the appropriate settings. In practice this is basically one call to ES or if you use
templates (which I recommend), a one-time setup for all your indices [1]

[1] http://www.elasticsearch.org/guide/en/elasticsearch/hadoop/current/mapping.html#_converting_data_to_elasticsearch

On 6/21/14 1:10 AM, shankarramshivram@gmail.com wrote:

Hi ,

My write to es from mapr fails because of the automatic date detection being enabled . Is there a way to disable date
detection from the external hive table properties. ?
Request to please guide me regarding this.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ed7e40b0-b896-4633-88fc-efdf2bead65a%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/ed7e40b0-b896-4633-88fc-efdf2bead65a%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/53A5F652.3030508%40gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3