Disabling norms in index creation not working


(Nikita Rastogi) #1

The use case is as follows:
1.) I am trying to disable norms for a particular field in the document while index creation .
2.) For this I have added a setting as follows in the mapping itself.
"mappings": {
"incident": {
"properties": {
"Filed1": {
"type": "string",
"norms": {
"enabled": false
},
"index": "analyzed",
"term_vector": "yes"

                        },
                        "Filed2": {
                            "type": "string",
                            "index": "analyzed",
                            "term_vector": "yes"
                        }
                    }
                },
                "dynamic_templates": [
                    {
                        "defaultFieldsNotIndexed": {
                            "match": "*",
                            "match_mapping_type": "*",
                            "mapping": {
                                "index": "no"
                            }
                        }
                    }
                ]

}
}
3.) While executing a more_like_this_query with explain being added in the Rest URL. I observed that the fieldnorm was getting calculated and was also included in the relevance score computation of the document. Following is a snippet:
'description': 'fieldNorm(doc=274)', 'details': [], 'value': 0.5}]
4.) The above query shows that the fieldnorm is not yet disabled.

Has anyone faced similar issue, or has any solution to th above problem,i.e., Disabling fieldnorm calculation in the relevance score.?


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.