How to create field without norms when creating an index


I am trying to create an index like so:
"my_new_index": {
"mappings": {
"my_mapping": {
"properties": {
"my_id": {
"type": "keyword",
"norms": false
But when I use the API to get the index I do not see 'norms' returned. Is there a way to disable norm creation when I create an index? Thanks in advance!

norms already defaults to false for fields of type keyword. Elasticsearch often won't return parameters that are set to the defaults. (Try setting norms to `true', and you will see that Elasticsearch will return that setting in the mapping when you retrieve it, because you have set it to a non-default value).

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.