Disabling Replica Shard Check

I am running a single node ES with no replica's and monitoring it via icinga/nagios. I have set the replica shards to 0 via the curl command

curl -XPUT 'localhost:9200/_settings?pretty' -H 'Content-Type: application/json' -d' { "index" : { "number_of_replicas" : 0 } } '

but the problem is the warning still appears every day on my nagios dashboard.

Detail: One or more indexes are missing replica shards. Use -vv to list them.

Is there a way to permanently suppress the warning? or set the value of replica shards to 0 via any configuration file?

You will need to change your index templates to have no replicas.

Can you point me to any documentation or an example?

Tried looking through curl -XGET 'localhost:9200/_template?pretty' but can't see any thing related to number_of_replica

You need to explicitly set it, eg https://www.elastic.co/guide/en/elasticsearch/reference/5.6/indices-create-index.html#create-index-settings

Thanks, i was able to use the templates to set the number_of_replicas to 0.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.