Disabling source


(cbax007) #1

I recently downloaded elasticsearch 0.17.6 and was trying to set up an index where I have disabled the storage of the _source field. I used the REST API to create a new index like so:

http://localhost:9200/test

{
"mappings" : {
"person" :{
"_source" : {"enabled": false}
}
}
}

but when I do GET requests for persons I have successfully indexed, I am still getting the _source back. Am I missing something here?


(system) #2