Disallow memory-mapping

Are there any disadvantages of setting

node.store.allow_mmap=false

?

I'm trying to run 3 nodes via docker-compose on a openVZ machine and cant increase max_map_count from 65536 to 262144.
What is the worst that could happen and under what circumstances?

setting allow_mmap to false will make Elasticsearch use niofs store type for its indices instead of more efficient memory mapped mmapfs store type.