The right value of vm.max_map_count for elasticsearch

I found my cluster health is red,

and the es receive log events less and less

The phenomenon as follow:

So I checked the log of elasticsearch.

(more details:


nested: IOException[Map failed:
[this may be caused by lack of enough unfragmented virtual address space or too
restrictive virtual memory limits enforced by the operating system,
preventing us to map a chunk of 3054244 bytes. Please review 'ulimit -v',
'ulimit -m' (both should return 'unlimited'), and 'sysctl vm.max_map_count'.
More information:]];

So what should I set the value of vm.max_map_count .

Does anybody have such experience and give me a suggestion?

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit
For more options, visit