Discover: Request Timeout after 30000ms: ES


(Rahul Nama) #1

Hello Team

Greetings of the day!

I'm using ES on a node.

Node Specifications:
2 VCPUs, 50GB DISK, 8 GB RAM
Indices 4
Every Indice has less than 100mb of data.
When I'm trying to visualise an indice data in discover, it's displaying Request Timeout error as CPU is being utilized 100%. I have 10 shards for that particular indice.
Is there anything that I could to here to avoid this? I read I can increase the timeout but doing so will help me? is it a best practice?

Please do suggest. Thanks for your time as always

Rahul Nama


(Thiago Souza) #2

How much heap is set to JVM? Also, how many shards are there is this node (considering all open indices)?


(Rahul Nama) #3

Hello @thiago

I have 12 shards in this node. and heap memory set to jvm is 4GB.


(Thiago Souza) #4

So 2 VCPUs is not enough for that. We recommend at least for 4 cores. You can check Nodes hot_threads to get a better understanding of what's burning CPU.


(Christian Dahlqvist) #5

What is the average size of your documents? You can try disabling highlighting by setting doc_table:highlight to false under the advanced options tab as this can reduce CPU usage quite a bit.


(Rahul Nama) #6

@Christian_Dahlqvist

Size of Documents is very less(in kbs). Sure I will do that and give one more try

Thank you :slight_smile:


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.