Discovery.zen.minimum_master_nodes: 7 but still getting split brain


(Slackorama) #1

Hi --

I have the following in my settings:

{
  "persistent": {
    "discovery": {
      "zen": {
        "minimum_master_nodes": "7"
      }
    }
  }
}

Yet twice in the past week, I've had clusters with nodes less than 7 split off from my 12 node cluster and start up their own cluster.

Do I need another setting to avoid split brain?

Thanks in advance,


(Mark Walkom) #2

That's pretty odd what version are you on, are you running cross datacentre?
It'd be easier if you just used something like 3 and then had dedicated masters, or just have 3 master eligible out of the 12.


(Christian Dahlqvist) #3

Why are you passing the value as a string instead of an intager?


(Slackorama) #4

I actually pass it as an integer but when I pull it out of the settings it
comes back as a string.


(system) #5