Discovery.zen.minimum_master_nodes and gateway.recover_after_nodes does not work after upgrading to ES 1.0.1?


(David Smith-2) #1

We have 16 node cluster on 0.90.5. We built a new cluster for 1.0.1 (yes,
we will upgrade to 1.1.0 soon) but we experience this problem that I would
like help with.

In our 0.90.5 cluster, we had it configured as:

discovery.zen.minimum_master_nodes: 9
gateway.expected_nodes: 16
gateway.recover_after_nodes: 12

But when we built the 1.0.1 cluster with the same settings, all the nodes
return 503 when upon startup after checking status http://localhost:9200.

Had to turn that down as below to get it working and return 200 status as
usual.
discovery.zen.minimum_master_nodes: 1

gateway.expected_nodes: 16
gateway.recover_after_nodes: 1

Full elasticsearch yaml configs for both clusters
are: https://gist.github.com/ppat/9791741

Am I doing anything wrong? Or is this an issue?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a1a63c2e-5717-4cb4-b10f-323ccd37f2fc%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Smith-2) #2

Anybody? Help?

On Wednesday, March 26, 2014 4:00:14 PM UTC-4, David Smith wrote:

We have 16 node cluster on 0.90.5. We built a new cluster for 1.0.1 (yes,
we will upgrade to 1.1.0 soon) but we experience this problem that I would
like help with.

In our 0.90.5 cluster, we had it configured as:

discovery.zen.minimum_master_nodes: 9
gateway.expected_nodes: 16
gateway.recover_after_nodes: 12

But when we built the 1.0.1 cluster with the same settings, all the nodes
return 503 when upon startup after checking status http://localhost:9200.

Had to turn that down as below to get it working and return 200 status as
usual.
discovery.zen.minimum_master_nodes: 1

gateway.expected_nodes: 16
gateway.recover_after_nodes: 1

Full elasticsearch yaml configs for both clusters are:
https://gist.github.com/ppat/9791741

Am I doing anything wrong? Or is this an issue?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/93df5ea3-6638-4ebd-a8ef-453736f07f32%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3