Discovery.zen.minimum_master_nodes is set to -1 by default

We missed a very important configuration in our elasticsearch.yml


and the default for it seems to be -1 according to _cluster/settings

What would be the right steps to update our yml file with the above setting. should a rolling restart be sufficient. yesterday when we did a rolling restart (for some other purpose and not for updating this setting) and restarted the master nodes we started getting 503 for writes (i couldn't check the log actually to confirm what exactly was the issue)

What does a value of -1 signify?

-1 roughly means the same as 1. But I think you're using version 7.2, in which case this setting is ignored and should not be set.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.