Discrepancy on processed nodes


(David Patiashvili) #1

Hello,

I need help. I just updated to 0.90.3 to 0.90.9 Elasticsearch and my 2
nodes cluster I with different versions ...

I can not update the version of the node 0.90.3 or delete.

Any idea ?

Thanks.

$ curl -XGET http://localhost:9200/_nodes/process?pretty

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"YSSDK3IqQIuquOuFUv8wKg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.10",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 18494,
"max_file_descriptors" : 4096,
"mlockall" : true
}
},
"0Wjpr1C2Qcm-l3t6fyZ-UQ" : {
"name" : "Book",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 14758,
"max_file_descriptors" : 4096,
"mlockall" : false
}
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d5635fdc-beb4-4bf0-a2a9-abb09c9f55a8%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Tony Su) #2

Hi,
Your post looks somewhat similar to something I posted a few days ago.
Am unclear why you may be stuck with 2 nodes running different versions of
ES.
They both need to be the same version to function as a cluster.

Your output says your upgraded node is ES 0.90.10 (not 0.90.9).
Surely you can upgrade your node running 0.90.3 to this same version?
If you are having a problem, what are the steps you tried and the problem
you ran into?

Tony

On Monday, February 3, 2014 12:17:45 PM UTC-8, David Patiashvili wrote:

Hello,

I need help. I just updated to 0.90.3 to 0.90.9 Elasticsearch and my 2
nodes cluster I with different versions ...

I can not update the version of the node 0.90.3 or delete.

Any idea ?

Thanks.

$ curl -XGET http://localhost:9200/_nodes/process?pretty

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"YSSDK3IqQIuquOuFUv8wKg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.10",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 18494,
"max_file_descriptors" : 4096,
"mlockall" : true
}
},
"0Wjpr1C2Qcm-l3t6fyZ-UQ" : {
"name" : "Book",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 14758,
"max_file_descriptors" : 4096,
"mlockall" : false
}
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bb162659-eec8-4b2f-8145-0fbf3045b072%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Patiashvili) #3

I have no idea how this happened. Here is the manipulation performed:

$ curl -XGET http://localhost:9200/_nodes/process?pretty
{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"YSSDK3IqQIuquOuFUv8wKg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.10",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 18494,
"max_file_descriptors" : 4096,
"mlockall" : true
}
},
"0Wjpr1C2Qcm-l3t6fyZ-UQ" : {
"name" : "Book",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 14758,
"max_file_descriptors" : 4096,
"mlockall" : false
}
}
}
}

$ service elasticsearch stop

Stopping ElasticSearch...
Stopped ElasticSearch.

$ curl -XGET http://localhost:9200/_nodes/process?pretty

curl: (7) couldn't connect to host

$ cd ~/install/elasticsearch
$ cp /usr/local/share/elasticsearch/config/elasticsearch.yml
~/install/elasticsearch
$ wget
https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.90.11.tar.gz
$ tar -zxvf elasticsearch-0.90.11.tar.gz
$ rm -rf /usr/local/share/elasticsearch*
$ mv elasticsearch-0.90.11 /usr/local/share/elasticsearch
$ cd /usr/local/share
$ sudo chmod 755 elasticsearch
$ cd -
$ curl -L
http://github.com/elasticsearch/elasticsearch-servicewrapper/tarball/master
| tar -xz
$ sudo mv servicewrapper/service /usr/local/share/elasticsearch/bin/
$ rm -Rf servicewrapper
$ sudo /usr/local/share/elasticsearch/bin/service/elasticsearch remove

Detected Ubuntu:
Stopping ElasticSearch...
ElasticSearch was not running.
Removing ElasticSearch daemon from init.d...
Removing any system startup links for /etc/init.d/elasticsearch ...
/etc/rc0.d/K20elasticsearch
/etc/rc1.d/K20elasticsearch
/etc/rc2.d/S20elasticsearch
/etc/rc3.d/S20elasticsearch
/etc/rc4.d/S20elasticsearch
/etc/rc5.d/S20elasticsearch
/etc/rc6.d/K20elasticsearch

$ sudo /usr/local/share/elasticsearch/bin/service/elasticsearch install

Detected Ubuntu:
Installing the ElasticSearch daemon using init.d..
Adding system startup for /etc/init.d/elasticsearch ...
/etc/rc0.d/K20elasticsearch -> ../init.d/elasticsearch
/etc/rc1.d/K20elasticsearch -> ../init.d/elasticsearch
/etc/rc6.d/K20elasticsearch -> ../init.d/elasticsearch
/etc/rc2.d/S20elasticsearch -> ../init.d/elasticsearch
/etc/rc3.d/S20elasticsearch -> ../init.d/elasticsearch
/etc/rc4.d/S20elasticsearch -> ../init.d/elasticsearch
/etc/rc5.d/S20elasticsearch -> ../init.d/elasticsearch

$ cp ./elasticsearch.yml /usr/local/share/elasticsearch/config/
$ service elasticsearch start
$ curl -XGET http://localhost:9200/_nodes/process?pretty

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"ccMmhlTaSgigmkLuOFZTVQ" : {
"name" : "Firearm",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 2037,
"max_file_descriptors" : 4096,
"mlockall" : false
}
},
"WLsYqX09T06HcdU8Ztk3dg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.11",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 9642,
"max_file_descriptors" : 4096,
"mlockall" : true
}
}
}
}

Le lundi 3 février 2014 22:31:12 UTC+1, Tony Su a écrit :

Hi,
Your post looks somewhat similar to something I posted a few days ago.
Am unclear why you may be stuck with 2 nodes running different versions of
ES.
They both need to be the same version to function as a cluster.

Your output says your upgraded node is ES 0.90.10 (not 0.90.9).
Surely you can upgrade your node running 0.90.3 to this same version?
If you are having a problem, what are the steps you tried and the problem
you ran into?

Tony

On Monday, February 3, 2014 12:17:45 PM UTC-8, David Patiashvili wrote:

Hello,

I need help. I just updated to 0.90.3 to 0.90.9 Elasticsearch and my 2
nodes cluster I with different versions ...

I can not update the version of the node 0.90.3 or delete.

Any idea ?

Thanks.

$ curl -XGET http://localhost:9200/_nodes/process?pretty

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"YSSDK3IqQIuquOuFUv8wKg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.10",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 18494,
"max_file_descriptors" : 4096,
"mlockall" : true
}
},
"0Wjpr1C2Qcm-l3t6fyZ-UQ" : {
"name" : "Book",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 14758,
"max_file_descriptors" : 4096,
"mlockall" : false
}
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bc3e3f86-c301-47c4-a205-b4f30eddacb6%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Tony Su) #4

Hi David,
Your latest suggests you successfully removed your old ES, installed ES
0.90.11, copied your old elasticsearch.yml to your newly installed and
verified it's responding.

But, that's only one node.
Did you do the same for your other node?

And, then do you still have a problem?

Tony

On Wednesday, February 5, 2014 12:30:55 AM UTC-8, David Patiashvili wrote:

I have no idea how this happened. Here is the manipulation performed:

$ curl -XGET http://localhost:9200/_nodes/process?pretty
{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"YSSDK3IqQIuquOuFUv8wKg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.10",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 18494,
"max_file_descriptors" : 4096,
"mlockall" : true
}
},
"0Wjpr1C2Qcm-l3t6fyZ-UQ" : {
"name" : "Book",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 14758,
"max_file_descriptors" : 4096,
"mlockall" : false
}
}
}
}

$ service elasticsearch stop

Stopping ElasticSearch...
Stopped ElasticSearch.

$ curl -XGET http://localhost:9200/_nodes/process?pretty

curl: (7) couldn't connect to host

$ cd ~/install/elasticsearch
$ cp /usr/local/share/elasticsearch/config/elasticsearch.yml
~/install/elasticsearch
$ wget
https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.90.11.tar.gz
$ tar -zxvf elasticsearch-0.90.11.tar.gz
$ rm -rf /usr/local/share/elasticsearch*
$ mv elasticsearch-0.90.11 /usr/local/share/elasticsearch
$ cd /usr/local/share
$ sudo chmod 755 elasticsearch
$ cd -
$ curl -L
http://github.com/elasticsearch/elasticsearch-servicewrapper/tarball/master| tar -xz
$ sudo mv servicewrapper/service /usr/local/share/elasticsearch/bin/
$ rm -Rf servicewrapper
$ sudo /usr/local/share/elasticsearch/bin/service/elasticsearch remove

Detected Ubuntu:
Stopping ElasticSearch...
ElasticSearch was not running.
Removing ElasticSearch daemon from init.d...
Removing any system startup links for /etc/init.d/elasticsearch ...
/etc/rc0.d/K20elasticsearch
/etc/rc1.d/K20elasticsearch
/etc/rc2.d/S20elasticsearch
/etc/rc3.d/S20elasticsearch
/etc/rc4.d/S20elasticsearch
/etc/rc5.d/S20elasticsearch
/etc/rc6.d/K20elasticsearch

$ sudo /usr/local/share/elasticsearch/bin/service/elasticsearch install

Detected Ubuntu:
Installing the ElasticSearch daemon using init.d..
Adding system startup for /etc/init.d/elasticsearch ...
/etc/rc0.d/K20elasticsearch -> ../init.d/elasticsearch
/etc/rc1.d/K20elasticsearch -> ../init.d/elasticsearch
/etc/rc6.d/K20elasticsearch -> ../init.d/elasticsearch
/etc/rc2.d/S20elasticsearch -> ../init.d/elasticsearch
/etc/rc3.d/S20elasticsearch -> ../init.d/elasticsearch
/etc/rc4.d/S20elasticsearch -> ../init.d/elasticsearch
/etc/rc5.d/S20elasticsearch -> ../init.d/elasticsearch

$ cp ./elasticsearch.yml /usr/local/share/elasticsearch/config/
$ service elasticsearch start
$ curl -XGET http://localhost:9200/_nodes/process?pretty

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"ccMmhlTaSgigmkLuOFZTVQ" : {
"name" : "Firearm",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 2037,
"max_file_descriptors" : 4096,
"mlockall" : false
}
},
"WLsYqX09T06HcdU8Ztk3dg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.11",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 9642,
"max_file_descriptors" : 4096,
"mlockall" : true
}
}
}
}

Le lundi 3 février 2014 22:31:12 UTC+1, Tony Su a écrit :

Hi,
Your post looks somewhat similar to something I posted a few days ago.
Am unclear why you may be stuck with 2 nodes running different versions
of ES.
They both need to be the same version to function as a cluster.

Your output says your upgraded node is ES 0.90.10 (not 0.90.9).
Surely you can upgrade your node running 0.90.3 to this same version?
If you are having a problem, what are the steps you tried and the problem
you ran into?

Tony

On Monday, February 3, 2014 12:17:45 PM UTC-8, David Patiashvili wrote:

Hello,

I need help. I just updated to 0.90.3 to 0.90.9 Elasticsearch and my 2
nodes cluster I with different versions ...

I can not update the version of the node 0.90.3 or delete.

Any idea ?

Thanks.

$ curl -XGET http://localhost:9200/_nodes/process?pretty

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"YSSDK3IqQIuquOuFUv8wKg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.10",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 18494,
"max_file_descriptors" : 4096,
"mlockall" : true
}
},
"0Wjpr1C2Qcm-l3t6fyZ-UQ" : {
"name" : "Book",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 14758,
"max_file_descriptors" : 4096,
"mlockall" : false
}
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e29c4fdc-b4bf-4bc8-a39f-65a7d0033565%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Patiashvili) #5

Where can I find the other node?

Le mercredi 5 février 2014 17:17:51 UTC+1, Tony Su a écrit :

Hi David,
Your latest suggests you successfully removed your old ES, installed ES
0.90.11, copied your old elasticsearch.yml to your newly installed and
verified it's responding.

But, that's only one node.
Did you do the same for your other node?

And, then do you still have a problem?

Tony

On Wednesday, February 5, 2014 12:30:55 AM UTC-8, David Patiashvili wrote:

I have no idea how this happened. Here is the manipulation performed:

$ curl -XGET http://localhost:9200/_nodes/process?pretty
{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"YSSDK3IqQIuquOuFUv8wKg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.10",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 18494,
"max_file_descriptors" : 4096,
"mlockall" : true
}
},
"0Wjpr1C2Qcm-l3t6fyZ-UQ" : {
"name" : "Book",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 14758,
"max_file_descriptors" : 4096,
"mlockall" : false
}
}
}
}

$ service elasticsearch stop

Stopping ElasticSearch...
Stopped ElasticSearch.

$ curl -XGET http://localhost:9200/_nodes/process?pretty

curl: (7) couldn't connect to host

$ cd ~/install/elasticsearch
$ cp /usr/local/share/elasticsearch/config/elasticsearch.yml
~/install/elasticsearch
$ wget
https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.90.11.tar.gz
$ tar -zxvf elasticsearch-0.90.11.tar.gz
$ rm -rf /usr/local/share/elasticsearch*
$ mv elasticsearch-0.90.11 /usr/local/share/elasticsearch
$ cd /usr/local/share
$ sudo chmod 755 elasticsearch
$ cd -
$ curl -L
http://github.com/elasticsearch/elasticsearch-servicewrapper/tarball/master| tar -xz
$ sudo mv servicewrapper/service /usr/local/share/elasticsearch/bin/
$ rm -Rf servicewrapper
$ sudo /usr/local/share/elasticsearch/bin/service/elasticsearch remove

Detected Ubuntu:
Stopping ElasticSearch...
ElasticSearch was not running.
Removing ElasticSearch daemon from init.d...
Removing any system startup links for /etc/init.d/elasticsearch ...
/etc/rc0.d/K20elasticsearch
/etc/rc1.d/K20elasticsearch
/etc/rc2.d/S20elasticsearch
/etc/rc3.d/S20elasticsearch
/etc/rc4.d/S20elasticsearch
/etc/rc5.d/S20elasticsearch
/etc/rc6.d/K20elasticsearch

$ sudo /usr/local/share/elasticsearch/bin/service/elasticsearch install

Detected Ubuntu:
Installing the ElasticSearch daemon using init.d..
Adding system startup for /etc/init.d/elasticsearch ...
/etc/rc0.d/K20elasticsearch -> ../init.d/elasticsearch
/etc/rc1.d/K20elasticsearch -> ../init.d/elasticsearch
/etc/rc6.d/K20elasticsearch -> ../init.d/elasticsearch
/etc/rc2.d/S20elasticsearch -> ../init.d/elasticsearch
/etc/rc3.d/S20elasticsearch -> ../init.d/elasticsearch
/etc/rc4.d/S20elasticsearch -> ../init.d/elasticsearch
/etc/rc5.d/S20elasticsearch -> ../init.d/elasticsearch

$ cp ./elasticsearch.yml /usr/local/share/elasticsearch/config/
$ service elasticsearch start
$ curl -XGET http://localhost:9200/_nodes/process?pretty

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"ccMmhlTaSgigmkLuOFZTVQ" : {
"name" : "Firearm",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 2037,
"max_file_descriptors" : 4096,
"mlockall" : false
}
},
"WLsYqX09T06HcdU8Ztk3dg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.11",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 9642,
"max_file_descriptors" : 4096,
"mlockall" : true
}
}
}
}

Le lundi 3 février 2014 22:31:12 UTC+1, Tony Su a écrit :

Hi,
Your post looks somewhat similar to something I posted a few days ago.
Am unclear why you may be stuck with 2 nodes running different versions
of ES.
They both need to be the same version to function as a cluster.

Your output says your upgraded node is ES 0.90.10 (not 0.90.9).
Surely you can upgrade your node running 0.90.3 to this same version?
If you are having a problem, what are the steps you tried and the
problem you ran into?

Tony

On Monday, February 3, 2014 12:17:45 PM UTC-8, David Patiashvili wrote:

Hello,

I need help. I just updated to 0.90.3 to 0.90.9 Elasticsearch and my 2
nodes cluster I with different versions ...

I can not update the version of the node 0.90.3 or delete.

Any idea ?

Thanks.

$ curl -XGET http://localhost:9200/_nodes/process?pretty

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"YSSDK3IqQIuquOuFUv8wKg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.10",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 18494,
"max_file_descriptors" : 4096,
"mlockall" : true
}
},
"0Wjpr1C2Qcm-l3t6fyZ-UQ" : {
"name" : "Book",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 14758,
"max_file_descriptors" : 4096,
"mlockall" : false
}
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8f45c500-73e9-4965-a228-9622237fe411%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Patiashvili) #6

I just realized. The second node just LogStash. I just update now they are
has a single node ...

Le mercredi 5 février 2014 17:20:05 UTC+1, David Patiashvili a écrit :

Where can I find the other node?

Le mercredi 5 février 2014 17:17:51 UTC+1, Tony Su a écrit :

Hi David,
Your latest suggests you successfully removed your old ES, installed ES
0.90.11, copied your old elasticsearch.yml to your newly installed and
verified it's responding.

But, that's only one node.
Did you do the same for your other node?

And, then do you still have a problem?

Tony

On Wednesday, February 5, 2014 12:30:55 AM UTC-8, David Patiashvili wrote:

I have no idea how this happened. Here is the manipulation performed:

$ curl -XGET http://localhost:9200/_nodes/process?pretty
{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"YSSDK3IqQIuquOuFUv8wKg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.10",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 18494,
"max_file_descriptors" : 4096,
"mlockall" : true
}
},
"0Wjpr1C2Qcm-l3t6fyZ-UQ" : {
"name" : "Book",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 14758,
"max_file_descriptors" : 4096,
"mlockall" : false
}
}
}
}

$ service elasticsearch stop

Stopping ElasticSearch...
Stopped ElasticSearch.

$ curl -XGET http://localhost:9200/_nodes/process?pretty

curl: (7) couldn't connect to host

$ cd ~/install/elasticsearch
$ cp /usr/local/share/elasticsearch/config/elasticsearch.yml
~/install/elasticsearch
$ wget
https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.90.11.tar.gz
$ tar -zxvf elasticsearch-0.90.11.tar.gz
$ rm -rf /usr/local/share/elasticsearch*
$ mv elasticsearch-0.90.11 /usr/local/share/elasticsearch
$ cd /usr/local/share
$ sudo chmod 755 elasticsearch
$ cd -
$ curl -L
http://github.com/elasticsearch/elasticsearch-servicewrapper/tarball/master| tar -xz
$ sudo mv servicewrapper/service /usr/local/share/elasticsearch/bin/
$ rm -Rf servicewrapper
$ sudo /usr/local/share/elasticsearch/bin/service/elasticsearch remove

Detected Ubuntu:
Stopping ElasticSearch...
ElasticSearch was not running.
Removing ElasticSearch daemon from init.d...
Removing any system startup links for /etc/init.d/elasticsearch ...
/etc/rc0.d/K20elasticsearch
/etc/rc1.d/K20elasticsearch
/etc/rc2.d/S20elasticsearch
/etc/rc3.d/S20elasticsearch
/etc/rc4.d/S20elasticsearch
/etc/rc5.d/S20elasticsearch
/etc/rc6.d/K20elasticsearch

$ sudo /usr/local/share/elasticsearch/bin/service/elasticsearch install

Detected Ubuntu:
Installing the ElasticSearch daemon using init.d..
Adding system startup for /etc/init.d/elasticsearch ...
/etc/rc0.d/K20elasticsearch -> ../init.d/elasticsearch
/etc/rc1.d/K20elasticsearch -> ../init.d/elasticsearch
/etc/rc6.d/K20elasticsearch -> ../init.d/elasticsearch
/etc/rc2.d/S20elasticsearch -> ../init.d/elasticsearch
/etc/rc3.d/S20elasticsearch -> ../init.d/elasticsearch
/etc/rc4.d/S20elasticsearch -> ../init.d/elasticsearch
/etc/rc5.d/S20elasticsearch -> ../init.d/elasticsearch

$ cp ./elasticsearch.yml /usr/local/share/elasticsearch/config/
$ service elasticsearch start
$ curl -XGET http://localhost:9200/_nodes/process?pretty

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"ccMmhlTaSgigmkLuOFZTVQ" : {
"name" : "Firearm",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 2037,
"max_file_descriptors" : 4096,
"mlockall" : false
}
},
"WLsYqX09T06HcdU8Ztk3dg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.11",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 9642,
"max_file_descriptors" : 4096,
"mlockall" : true
}
}
}
}

Le lundi 3 février 2014 22:31:12 UTC+1, Tony Su a écrit :

Hi,
Your post looks somewhat similar to something I posted a few days ago.
Am unclear why you may be stuck with 2 nodes running different versions
of ES.
They both need to be the same version to function as a cluster.

Your output says your upgraded node is ES 0.90.10 (not 0.90.9).
Surely you can upgrade your node running 0.90.3 to this same version?
If you are having a problem, what are the steps you tried and the
problem you ran into?

Tony

On Monday, February 3, 2014 12:17:45 PM UTC-8, David Patiashvili wrote:

Hello,

I need help. I just updated to 0.90.3 to 0.90.9 Elasticsearch and my 2
nodes cluster I with different versions ...

I can not update the version of the node 0.90.3 or delete.

Any idea ?

Thanks.

$ curl -XGET http://localhost:9200/_nodes/process?pretty

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"YSSDK3IqQIuquOuFUv8wKg" : {
"name" : "David",
"transport_address" : "inet[/127.0.0.1:9300]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.10",
"http_address" : "inet[/127.0.0.1:9200]",
"attributes" : {
"max_local_storage_nodes" : "1",
"master" : "true"
},
"process" : {
"refresh_interval" : 1000,
"id" : 18494,
"max_file_descriptors" : 4096,
"mlockall" : true
}
},
"0Wjpr1C2Qcm-l3t6fyZ-UQ" : {
"name" : "Book",
"transport_address" : "inet[/26.220.169.56:9301]",
"hostname" : "Webmaster-Server-2",
"version" : "0.90.3",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval" : 1000,
"id" : 14758,
"max_file_descriptors" : 4096,
"mlockall" : false
}
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8a7162a8-d550-4e41-8404-11d44e03d2aa%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Binh Ly) #7

Yup,

When you look closely at the _node results, one node has these
characteristics:

  "attributes" : {
    "client" : "true",
    "data" : "false"
  },

This means the node is a client node and is not a data node.

On Tuesday, February 11, 2014 10:06:47 AM UTC-5, David Patiashvili wrote:

I just realized. The second node just LogStash. I just update now they are
has a single node ...

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e0f320c0-869d-46cd-9bc1-6725a14fb9ec%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #8