Elasticsearch upgrade from 0.90.0 to 0.90.12


(Patrick Shan) #1

Hi there,

I am planning to do an upgrade for our current Elasticsearch cluster which
is using version 0.90.0. I am thinking to add the new version (v0.90.12) of
ES nodes ( master nodes first and then data nodes ) to the cluster and take
the old version of nodes out of cluster.

Is there any known issue with these two versions (v0.90.0 and v0.90.12) of
elasticsearch working with each other in the same cluster?

I checked the release notes and found some breaking changes from 0.90.0 to
0.90.12. Will these breaking changes cause any problem with this upgrade ?

Thanks.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2f1cec28-7bbf-4d4e-a05a-fe758d3c20f0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Patrick Shan) #2

Anyone can shade some light on this ?

Thanks

On Wednesday, March 19, 2014 6:09:22 PM UTC+11, Patrick Shan wrote:

Hi there,

I am planning to do an upgrade for our current Elasticsearch cluster
which is using version 0.90.0. I am thinking to add the new version
(v0.90.12) of ES nodes ( master nodes first and then data nodes ) to the
cluster and take the old version of nodes out of cluster.

Is there any known issue with these two versions (v0.90.0 and v0.90.12) of
elasticsearch working with each other in the same cluster?

I checked the release notes and found some breaking changes from 0.90.0 to
0.90.12. Will these breaking changes cause any problem with this upgrade ?

Thanks.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/56191b2b-c44f-4d56-a81f-6cccbada00a0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #3

There's a number of underlying lucene changes between those versions that
may cause problems.
It'd be worth checking that and perhaps plan on upgrading a few point
releases at a time. There is a few threads on this in the archives as well.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 20 March 2014 14:24, Patrick Shan patrickshan.syd@gmail.com wrote:

Anyone can shade some light on this ?

Thanks

On Wednesday, March 19, 2014 6:09:22 PM UTC+11, Patrick Shan wrote:

Hi there,

I am planning to do an upgrade for our current Elasticsearch cluster
which is using version 0.90.0. I am thinking to add the new version
(v0.90.12) of ES nodes ( master nodes first and then data nodes ) to the
cluster and take the old version of nodes out of cluster.

Is there any known issue with these two versions (v0.90.0 and v0.90.12)
of elasticsearch working with each other in the same cluster?

I checked the release notes and found some breaking changes from 0.90.0
to 0.90.12. Will these breaking changes cause any problem with this upgrade
?

Thanks.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/56191b2b-c44f-4d56-a81f-6cccbada00a0%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/56191b2b-c44f-4d56-a81f-6cccbada00a0%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624bdBOZUiQ3N%3Dg3_hE-%2BTCsh8QaYt_eJ4iQoY4EC26gWdg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Patrick Shan) #4

Thanks Mark. I'll check it.

On Thursday, March 20, 2014 3:24:08 PM UTC+11, Mark Walkom wrote:

There's a number of underlying lucene changes between those versions that
may cause problems.
It'd be worth checking that and perhaps plan on upgrading a few point
releases at a time. There is a few threads on this in the archives as well.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 20 March 2014 14:24, Patrick Shan <patrick...@gmail.com <javascript:>>wrote:

Anyone can shade some light on this ?

Thanks

On Wednesday, March 19, 2014 6:09:22 PM UTC+11, Patrick Shan wrote:

Hi there,

I am planning to do an upgrade for our current Elasticsearch cluster
which is using version 0.90.0. I am thinking to add the new version
(v0.90.12) of ES nodes ( master nodes first and then data nodes ) to the
cluster and take the old version of nodes out of cluster.

Is there any known issue with these two versions (v0.90.0 and v0.90.12)
of elasticsearch working with each other in the same cluster?

I checked the release notes and found some breaking changes from 0.90.0
to 0.90.12. Will these breaking changes cause any problem with this upgrade
?

Thanks.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/56191b2b-c44f-4d56-a81f-6cccbada00a0%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/56191b2b-c44f-4d56-a81f-6cccbada00a0%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/97614890-f138-419f-ad4d-e748f27ff0f7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #5