Distribute System Fail


(Sang Dang) #1

Hi All,

I just try to use ElasticSearch.
It's my first time to work with it so I need your help.

I setup 3 computers.

PC #1: Run normal ES with cluster name: "tested_cluster"
PC #2: Run normal ES with same above cluster name.
PC #3: Run ES with same above cluster name. (PC #3 is my pc, and it don't
hold data, it's a master node).

It's is the info of each node:

PC#1: http://10.30.12.12:9200/_cluster/nodes?pretty=true

{
"ok" : true,
"cluster_name" : "tested_cluster",
"nodes" : {
"35P43iugS_SKs347cGqedA" : {
"name" : "Bushmaster",
"transport_address" : "inet[/10.30.12.12:9300]",
"http_address" : "inet[/10.30.12.12:9200]"
}
}
}

PC#2: http://10.30.12.94:9200/_cluster/nodes?pretty=true

{
"ok" : true,
"cluster_name" : "tested_cluster",
"nodes" : {
"r25GkH15Rz6N-f8LaWw3TA" : {
"name" : "Baphomet",
"transport_address" : "inet[10.30.12.94/10.30.12.94:9300]",
"hostname" : "WT_ZME_APPS-12.94",
"http_address" : "inet[/10.30.12.94:9200]"
}
}
}

And My PC: http://localhost:9200/_cluster/nodes?pretty=true

{
"ok" : true,
"cluster_name" : "es_zingstore",
"nodes" : {
"ixbOo4JnT-OUlA3WIhxdPA" : {
"name" : "Grappler",
"transport_address" : "inet[/10.199.25.67:9300]",
"hostname" : "zkidkid",
"http_address" : "inet[/10.199.25.67:9200]",
"attributes" : {
"data" : "false",
"master" : "true"
}
}
}
}

I think the problem is by setting discovery, but I don't know how, I have read the guide & tut more than 3 but found nothing.

Thanks.

--


(Lukáš Vlček) #2

Hi,

you want all three computers to form a single cluster? You can try setting
logging level to debug and check the log files to see if it can see the
other nodes. May be there is some firewall blocking it? I would recommend
you to use and tune just two nodes first and once they can connect, add the
third node.

Also, it is probably just wrong cut&paste but in your example one node uses
a different cluster_name.

Lukas

On Tue, Sep 11, 2012 at 5:26 AM, kidkid zkidkid@gmail.com wrote:

Hi All,

I just try to use ElasticSearch.
It's my first time to work with it so I need your help.

I setup 3 computers.

PC #1: Run normal ES with cluster name: "tested_cluster"
PC #2: Run normal ES with same above cluster name.
PC #3: Run ES with same above cluster name. (PC #3 is my pc, and it don't
hold data, it's a master node).

It's is the info of each node:

PC#1: http://10.30.12.12:9200/_cluster/nodes?pretty=true

{
"ok" : true,
"cluster_name" : "tested_cluster",
"nodes" : {
"35P43iugS_SKs347cGqedA" : {
"name" : "Bushmaster",
"transport_address" : "inet[/10.30.12.12:9300]",
"http_address" : "inet[/10.30.12.12:9200]"
}
}
}

PC#2: http://10.30.12.94:9200/_cluster/nodes?pretty=true

{
"ok" : true,
"cluster_name" : "tested_cluster",
"nodes" : {
"r25GkH15Rz6N-f8LaWw3TA" : {
"name" : "Baphomet",
"transport_address" : "inet[10.30.12.94/10.30.12.94:9300]",
"hostname" : "WT_ZME_APPS-12.94",
"http_address" : "inet[/10.30.12.94:9200]"
}
}
}

And My PC: http://localhost:9200/_cluster/nodes?pretty=true

{
"ok" : true,
"cluster_name" : "es_zingstore",
"nodes" : {
"ixbOo4JnT-OUlA3WIhxdPA" : {
"name" : "Grappler",
"transport_address" : "inet[/10.199.25.67:9300]",
"hostname" : "zkidkid",
"http_address" : "inet[/10.199.25.67:9200]",
"attributes" : {
"data" : "false",
"master" : "true"
}
}
}
}

I think the problem is by setting discovery, but I don't know how, I have read the guide & tut more than 3 but found nothing.

Thanks.

--

--


(Sang Dang) #3

Hi Lukas,

Thanks for your reply.
You right, the cluster_name is wrong cut&paste.
3 is running in same cluster name.

I have make it running now by use unicast.
Thanks again.

P/S: I am tired with analyzer & filter, all is totally new with me. I am
reading it, the ES document is not clear much. Maybe I will need help again
:expressionless:
I google now. Thank & nice day for all.

On Wednesday, September 12, 2012 3:02:37 AM UTC+7, Lukáš Vlček wrote:

Hi,

you want all three computers to form a single cluster? You can try setting
logging level to debug and check the log files to see if it can see the
other nodes. May be there is some firewall blocking it? I would recommend
you to use and tune just two nodes first and once they can connect, add the
third node.

Also, it is probably just wrong cut&paste but in your example one node
uses a different cluster_name.

Lukas

On Tue, Sep 11, 2012 at 5:26 AM, kidkid <zki...@gmail.com <javascript:>>wrote:

Hi All,

I just try to use ElasticSearch.
It's my first time to work with it so I need your help.

I setup 3 computers.

PC #1: Run normal ES with cluster name: "tested_cluster"
PC #2: Run normal ES with same above cluster name.
PC #3: Run ES with same above cluster name. (PC #3 is my pc, and it don't
hold data, it's a master node).

It's is the info of each node:

PC#1: http://10.30.12.12:9200/_cluster/nodes?pretty=true

{
"ok" : true,
"cluster_name" : "tested_cluster",
"nodes" : {
"35P43iugS_SKs347cGqedA" : {
"name" : "Bushmaster",
"transport_address" : "inet[/10.30.12.12:9300]",
"http_address" : "inet[/10.30.12.12:9200]"
}
}
}

PC#2: http://10.30.12.94:9200/_cluster/nodes?pretty=true

{
"ok" : true,
"cluster_name" : "tested_cluster",
"nodes" : {
"r25GkH15Rz6N-f8LaWw3TA" : {
"name" : "Baphomet",
"transport_address" : "inet[10.30.12.94/10.30.12.94:9300]",
"hostname" : "WT_ZME_APPS-12.94",
"http_address" : "inet[/10.30.12.94:9200]"
}
}
}

And My PC: http://localhost:9200/_cluster/nodes?pretty=true

{
"ok" : true,
"cluster_name" : "es_zingstore",
"nodes" : {
"ixbOo4JnT-OUlA3WIhxdPA" : {
"name" : "Grappler",
"transport_address" : "inet[/10.199.25.67:9300]",
"hostname" : "zkidkid",
"http_address" : "inet[/10.199.25.67:9200]",
"attributes" : {
"data" : "false",
"master" : "true"
}
}
}
}

I think the problem is by setting discovery, but I don't know how, I have read the guide & tut more than 3 but found nothing.

Thanks.

--

--


(system) #4