DNS Lookup


(Daniel Mack) #1

Hello, i have installed Elasticsearch, Kibana and Fluentd on Debian 7.0
with rsyslog for Logging Network devices like Switches and Firewalls. I get
from the Firewall the hostname and see it in Kibana but from the Switches
get I only the IP Address. We don't want to have the Switches on the DNS
Server but i have written the Hostnames and the IP Adresses from the
Switches in etc/hosts on the Debian Server.
But the resolution did not go.

What can i do?

Best Regards

Daniel

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2f313529-ddfb-4f83-93c7-c321543e1478%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Walkom) #2

You'll have to add it to DNS.

I think the hosts file can be used like that, but it'd depend on the
application reading it to do the translation.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 30 January 2014 22:05, Daniel Mack daniel21mack@googlemail.com wrote:

Hello, i have installed Elasticsearch, Kibana and Fluentd on Debian 7.0
with rsyslog for Logging Network devices like Switches and Firewalls. I get
from the Firewall the hostname and see it in Kibana but from the Switches
get I only the IP Address. We don't want to have the Switches on the DNS
Server but i have written the Hostnames and the IP Adresses from the
Switches in etc/hosts on the Debian Server.
But the resolution did not go.

What can i do?

Best Regards

Daniel

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2f313529-ddfb-4f83-93c7-c321543e1478%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624bzMBXYGj5j7ROvzP4FscRB92FUCbBK5ec3ksNyQQ59Nw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #3

It's not a specific ES question, you should ask your network administrator
for assistance.

If your firewall can provide the hostname (or better, the DHCP daemon of
your firewall/router?) you should be able to configure your hosts to
receive the DHCP host name at boot time.

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoE1Z1tXBCmnip78OA8FjOKGZgYTL3mhQmvWz0Zb9-H6cg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4