Docker restarting with security.enabled:false


(JoelIncoming) #1

Hi ppl,
I'm trying to enable login on kibana 6.1, I read i must set xpack.security.enabled: false
I got it like you'll see now, but the docker don't stop restarting.
imagen

When i try to start it with -i it says :

Then when i try with the xpack.security.enabled: true, it works fine but i have not login option in kibana.


(David Pilato) #2

Please don't post images of text as they are hardly readable and not searchable.

Instead paste the text and format it with </> icon. Check the preview window.


(JoelIncoming) #3

Sorry about that.
The first one:

# Default Kibana configuration from kibana-docker.
server.name: kibana
server.host: "0"
elasticsearch.url: http://192.168.1.43:9200
xpack.security.enabled: true
elasticsearch.username: elastic
elasticsearch.password: Admin12345.
xpack.monitoring.ui.container.elasticsearch.enabled: true
xpack.security.encryptionKey: "something_at_least_32_characters"
xpack.security.sessionTimeout: 600000

The second image:

docker start -i gisystem_kibana_1
{"type":"log","@timestamp":"2018-03-02T10:25:31Z","tags":["fatal"],"pid":1,"message":"\"xpack.security.encryptionKey\" and \"xpack.security.sessionTimeout\" settings were not applied. Check for spelling errors and ensure that expected plugins are installed and enabled."}
FATAL "xpack.security.encryptionKey" and "xpack.security.sessionTimeout" settings were not applied. Check for spelling errors and ensure that expected plugins are installed and enabled.

(David Pilato) #4

In case it helps, here is the Docker compose file I'm using:

---
version: '3'
services:

  elasticsearch:
    image: docker.elastic.co/elasticsearch/elasticsearch-platinum:$ELASTIC_VERSION
    environment:
      - bootstrap.memory_lock=true
      - ELASTIC_PASSWORD=changeme
      - discovery.type=single-node
      - "ES_JAVA_OPTS=-Xms2g -Xmx2g"
      - cluster.routing.allocation.disk.threshold_enabled=false
      - xpack.security.enabled=false
    ulimits:
      memlock:
        soft: -1
        hard: -1
    ports:
      - 9200:9200
    networks: ['stack']

  kibana:
    image: docker.elastic.co/kibana/kibana:$ELASTIC_VERSION
    links:
      - elasticsearch
    ports:
      - 5601:5601
    networks: ['stack']
    depends_on:
      - elasticsearch

networks:
  stack: {}

(Tim Vernum) #5

It looks like you're using a Kibana image that doesn't include X-Pack.
What does your docker configuration look like?


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.