Document found with _search but not with GET


(Pir Abdul Rasool Qureshi) #1

Hi

We have a single machine elastic search server (8 shards but all hosted at
the same machine). Index contains 7 million documents. We do not specify
any custom routing when indexing the documents. We are using Elastic search
version 1.2.

The problem is that we are unable to retrieve many of our documents using GET
, . However using search?_id: we are able to retrieve all
of those documents.

We are also successful in retrieving a document by specifying routing
parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that
problem.

Any suggestions for resolution?

Thanks in advance

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Can not get any result from indexed indice
(Itamar Syn-Hershko) #2

What is the exact URLs you're approaching? Are you specifying the index
name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi <
pir@colourbox.com> wrote:

Hi

We have a single machine elastic search server (8 shards but all hosted at
the same machine). Index contains 7 million documents. We do not specify
any custom routing when indexing the documents. We are using Elastic search
version 1.2.

The problem is that we are unable to retrieve many of our documents using GET
, . However using search?_id: we are able to retrieve all
of those documents.

We are also successful in retrieving a document by specifying routing
parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that
problem.

Any suggestions for resolution?

Thanks in advance

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zs6gaOhO2ZG%2B9Sm01gByVHa32cdGpZ_uDmpuJvWksLZVQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Pir Abdul Rasool Qureshi) #3

Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:

What is the exact URLs you're approaching? Are you specifying the index
name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com <javascript:>> wrote:

Hi

We have a single machine elastic search server (8 shards but all hosted
at the same machine). Index contains 7 million documents. We do not specify
any custom routing when indexing the documents. We are using Elastic search
version 1.2.

The problem is that we are unable to retrieve many of our documents using GET
, . However using search?_id: we are able to retrieve
all of those documents.

We are also successful in retrieving a document by specifying routing
parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that
problem.

Any suggestions for resolution?

Thanks in advance

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Itamar Syn-Hershko) #4

When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi <
pir@colourbox.com> wrote:

Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:

What is the exact URLs you're approaching? Are you specifying the index
name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com> wrote:

Hi

We have a single machine elastic search server (8 shards but all hosted
at the same machine). Index contains 7 million documents. We do not specify
any custom routing when indexing the documents. We are using Elastic search
version 1.2.

The problem is that we are unable to retrieve many of our documents
using GET , . However using search?_id: we are able to
retrieve all of those documents.

We are also successful in retrieving a document by specifying routing
parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that
problem.

Any suggestions for resolution?

Thanks in advance

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHTr4ZvvBFmb5aJhBjpqvHzAuus-AaAVwE_htP8EjgX8c%2BpBig%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Pir Abdul Rasool Qureshi) #5

It gives me the (expected) value i.e. 3624608.

Details:

Query 1:

If I do curl -XGET
"http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608",
it retrieves a single document with _id = 3624608

Query 2:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/3624608"
it results in
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"found": false
}

Query 3:

If I do curl -XGET "http://somehost:9200/OurIndex/OurType/3624608?routing=1"
it retrieves a single document with _id = 3624608

Thanks

On Monday, May 26, 2014 12:14:26 PM UTC+2, Itamar Syn-Hershko wrote:

When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com <javascript:>> wrote:

Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:

What is the exact URLs you're approaching? Are you specifying the index
name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com> wrote:

Hi

We have a single machine elastic search server (8 shards but all hosted
at the same machine). Index contains 7 million documents. We do not specify
any custom routing when indexing the documents. We are using Elastic search
version 1.2.

The problem is that we are unable to retrieve many of our documents
using GET , . However using search?_id: we are able to
retrieve all of those documents.

We are also successful in retrieving a document by specifying routing
parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that
problem.

Any suggestions for resolution?

Thanks in advance

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #6

Are you using parent child ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 13:50, Pir Abdul Rasool Qureshi pir@colourbox.com a écrit :

It gives me the (expected) value i.e. 3624608.

Details:

Query 1:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608",
it retrieves a single document with _id = 3624608

Query 2:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/3624608"
it results in
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"found": false
}

Query 3:

If I do curl -XGET "http://somehost:9200/OurIndex/OurType/3624608?routing=1"
it retrieves a single document with _id = 3624608

Thanks

On Monday, May 26, 2014 12:14:26 PM UTC+2, Itamar Syn-Hershko wrote:
When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi p...@colourbox.com wrote:
Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:
What is the exact URLs you're approaching? Are you specifying the index name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi p...@colourbox.com wrote:
Hi

We have a single machine elastic search server (8 shards but all hosted at the same machine). Index contains 7 million documents. We do not specify any custom routing when indexing the documents. We are using Elastic search version 1.2.

The problem is that we are unable to retrieve many of our documents using GET , . However using search?_id: we are able to retrieve all of those documents.

We are also successful in retrieving a document by specifying routing parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that problem.

Any suggestions for resolution?

Thanks in advance

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/50F0DF13-6336-4508-9267-B6E1395B4C85%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(Pir Abdul Rasool Qureshi) #7

No, We are not using Parent/Child.

On Monday, May 26, 2014 1:54:11 PM UTC+2, David Pilato wrote:

Are you using parent child ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 13:50, Pir Abdul Rasool Qureshi <p...@colourbox.com<javascript:>>
a écrit :

It gives me the (expected) value i.e. 3624608.

Details:

Query 1:

If I do curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608",
it retrieves a single document with _id = 3624608

Query 2:

If I do curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/3624608"
it results in
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"found": false
}

Query 3:

If I do curl -XGET "
http://somehost:9200/OurIndex/OurType/3624608?routing=1"
it retrieves a single document with _id = 3624608

Thanks

On Monday, May 26, 2014 12:14:26 PM UTC+2, Itamar Syn-Hershko wrote:

When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com> wrote:

Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:

What is the exact URLs you're approaching? Are you specifying the index
name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com> wrote:

Hi

We have a single machine elastic search server (8 shards but all
hosted at the same machine). Index contains 7 million documents. We do not
specify any custom routing when indexing the documents. We are using
Elastic search version 1.2.

The problem is that we are unable to retrieve many of our documents
using GET , . However using search?_id: we are able
to retrieve all of those documents.

We are also successful in retrieving a document by specifying routing
parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that
problem.

Any suggestions for resolution?

Thanks in advance

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/40eec5a2-55b2-4841-8618-dd54711d1062%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #8

What is your mapping?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 14:59, Pir Abdul Rasool Qureshi pir@colourbox.com a écrit :

No, We are not using Parent/Child.

On Monday, May 26, 2014 1:54:11 PM UTC+2, David Pilato wrote:
Are you using parent child ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 13:50, Pir Abdul Rasool Qureshi p...@colourbox.com a écrit :

It gives me the (expected) value i.e. 3624608.

Details:

Query 1:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608",
it retrieves a single document with _id = 3624608

Query 2:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/3624608"
it results in
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"found": false
}

Query 3:

If I do curl -XGET "http://somehost:9200/OurIndex/OurType/3624608?routing=1"
it retrieves a single document with _id = 3624608

Thanks

On Monday, May 26, 2014 12:14:26 PM UTC+2, Itamar Syn-Hershko wrote:
When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi p...@colourbox.com wrote:
Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:
What is the exact URLs you're approaching? Are you specifying the index name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi p...@colourbox.com wrote:
Hi

We have a single machine elastic search server (8 shards but all hosted at the same machine). Index contains 7 million documents. We do not specify any custom routing when indexing the documents. We are using Elastic search version 1.2.

The problem is that we are unable to retrieve many of our documents using GET , . However using search?_id: we are able to retrieve all of those documents.

We are also successful in retrieving a document by specifying routing parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that problem.

Any suggestions for resolution?

Thanks in advance

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/40eec5a2-55b2-4841-8618-dd54711d1062%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/D0E8A1D6-2150-402B-90C1-BD6E762498CB%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(Pir Abdul Rasool Qureshi) #9

{
"OurIndex": {
"mappings": {
"OurType": {
"properties": {
"added": {
"type": "date",
"format": "dateOptionalTime"
},
"adult_content": {
"type": "boolean"
},
"bucket_id": {
"type": "short"
},
"company_id": {
"type": "long"
},
"created": {
"type": "date",
"format": "dateOptionalTime"
},
"da_keywords_1": {
"type": "string"
},
"da_keywords_2": {
"type": "string"
},
"da_keywords_3": {
"type": "string"
},
"da_keywords_4": {
"type": "string"
},
"da_keywords_5": {
"type": "string"
},
"da_text_keywords_1": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_2": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_3": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_4": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_5": {
"type": "string",
"analyzer": "danish"
},
"da_text_title": {
"type": "string",
"analyzer": "danish"
},
"da_title": {
"type": "string"
},
"de_keywords_1": {
"type": "string"
},
"de_keywords_2": {
"type": "string"
},
"de_keywords_3": {
"type": "string"
},
"de_keywords_4": {
"type": "string"
},
"de_keywords_5": {
"type": "string"
},
"de_text_keywords_1": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_2": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_3": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_4": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_5": {
"type": "string",
"analyzer": "german"
},
"de_text_title": {
"type": "string",
"analyzer": "german"
},
"de_title": {
"type": "string"
},
"dimension": {
"type": "string"
},
"duration": {
"type": "integer"
},
"editorial": {
"type": "string"
},
"en_keywords_1": {
"type": "string"
},
"en_keywords_2": {
"type": "string"
},
"en_keywords_3": {
"type": "string"
},
"en_keywords_4": {
"type": "string"
},
"en_keywords_5": {
"type": "string"
},
"en_text_keywords_1": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_2": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_3": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_4": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_5": {
"type": "string",
"analyzer": "english"
},
"en_text_title": {
"type": "string",
"analyzer": "english"
},
"en_title": {
"type": "string"
},
"folder_ids": {
"type": "long"
},
"height": {
"type": "integer"
},
"id": {
"type": "string"
},
"f_id": {
"type": "long"
},
"media_type": {
"type": "string"
},
"orientation": {
"type": "string"
},
"published": {
"type": "date",
"format": "dateOptionalTime"
},
"resolution": {
"type": "string"
},
"status": {
"type": "string"
},
"supplier_id": {
"type": "long"
},
"db_id": {
"type": "long"
},
"width": {
"type": "integer"
}
}
}
}
}
}

On Monday, May 26, 2014 3:09:18 PM UTC+2, David Pilato wrote:

What is your mapping?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 14:59, Pir Abdul Rasool Qureshi <p...@colourbox.com<javascript:>>
a écrit :

No, We are not using Parent/Child.

On Monday, May 26, 2014 1:54:11 PM UTC+2, David Pilato wrote:

Are you using parent child ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 13:50, Pir Abdul Rasool Qureshi p...@colourbox.com a
écrit :

It gives me the (expected) value i.e. 3624608.

Details:

Query 1:

If I do curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608",
it retrieves a single document with _id = 3624608

Query 2:

If I do curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/3624608"
it results in
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"found": false
}

Query 3:

If I do curl -XGET "
http://somehost:9200/OurIndex/OurType/3624608?routing=1"
it retrieves a single document with _id = 3624608

Thanks

On Monday, May 26, 2014 12:14:26 PM UTC+2, Itamar Syn-Hershko wrote:

When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com> wrote:

Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:

What is the exact URLs you're approaching? Are you specifying the
index name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com> wrote:

Hi

We have a single machine elastic search server (8 shards but all
hosted at the same machine). Index contains 7 million documents. We do not
specify any custom routing when indexing the documents. We are using
Elastic search version 1.2.

The problem is that we are unable to retrieve many of our documents
using GET , . However using search?_id: we are able
to retrieve all of those documents.

We are also successful in retrieving a document by specifying routing
parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have
that problem.

Any suggestions for resolution?

Thanks in advance

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/40eec5a2-55b2-4841-8618-dd54711d1062%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/40eec5a2-55b2-4841-8618-dd54711d1062%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7166fa5a-6182-49ae-9666-28fb2fa43da2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #10

Are you sure you are not using any routing value when indexing?

If so, could you recreate a curl/Sense recreation which reproduce the problem?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 26 mai 2014 à 15:30:43, Pir Abdul Rasool Qureshi (pir@colourbox.com) a écrit:

{
"OurIndex": {
"mappings": {
"OurType": {
"properties": {
"added": {
"type": "date",
"format": "dateOptionalTime"
},
"adult_content": {
"type": "boolean"
},
"bucket_id": {
"type": "short"
},
"company_id": {
"type": "long"
},
"created": {
"type": "date",
"format": "dateOptionalTime"
},
"da_keywords_1": {
"type": "string"
},
"da_keywords_2": {
"type": "string"
},
"da_keywords_3": {
"type": "string"
},
"da_keywords_4": {
"type": "string"
},
"da_keywords_5": {
"type": "string"
},
"da_text_keywords_1": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_2": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_3": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_4": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_5": {
"type": "string",
"analyzer": "danish"
},
"da_text_title": {
"type": "string",
"analyzer": "danish"
},
"da_title": {
"type": "string"
},
"de_keywords_1": {
"type": "string"
},
"de_keywords_2": {
"type": "string"
},
"de_keywords_3": {
"type": "string"
},
"de_keywords_4": {
"type": "string"
},
"de_keywords_5": {
"type": "string"
},
"de_text_keywords_1": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_2": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_3": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_4": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_5": {
"type": "string",
"analyzer": "german"
},
"de_text_title": {
"type": "string",
"analyzer": "german"
},
"de_title": {
"type": "string"
},
"dimension": {
"type": "string"
},
"duration": {
"type": "integer"
},
"editorial": {
"type": "string"
},
"en_keywords_1": {
"type": "string"
},
"en_keywords_2": {
"type": "string"
},
"en_keywords_3": {
"type": "string"
},
"en_keywords_4": {
"type": "string"
},
"en_keywords_5": {
"type": "string"
},
"en_text_keywords_1": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_2": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_3": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_4": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_5": {
"type": "string",
"analyzer": "english"
},
"en_text_title": {
"type": "string",
"analyzer": "english"
},
"en_title": {
"type": "string"
},
"folder_ids": {
"type": "long"
},
"height": {
"type": "integer"
},
"id": {
"type": "string"
},
"f_id": {
"type": "long"
},
"media_type": {
"type": "string"
},
"orientation": {
"type": "string"
},
"published": {
"type": "date",
"format": "dateOptionalTime"
},
"resolution": {
"type": "string"
},
"status": {
"type": "string"
},
"supplier_id": {
"type": "long"
},
"db_id": {
"type": "long"
},
"width": {
"type": "integer"
}
}
}
}
}
}

On Monday, May 26, 2014 3:09:18 PM UTC+2, David Pilato wrote:
What is your mapping?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 14:59, Pir Abdul Rasool Qureshi p...@colourbox.com a écrit :

No, We are not using Parent/Child.

On Monday, May 26, 2014 1:54:11 PM UTC+2, David Pilato wrote:
Are you using parent child ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 13:50, Pir Abdul Rasool Qureshi p...@colourbox.com a écrit :

It gives me the (expected) value i.e. 3624608.

Details:

Query 1:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608",
it retrieves a single document with _id = 3624608

Query 2:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/3624608"
it results in
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"found": false
}

Query 3:

If I do curl -XGET "http://somehost:9200/OurIndex/OurType/3624608?routing=1"
it retrieves a single document with _id = 3624608

Thanks

On Monday, May 26, 2014 12:14:26 PM UTC+2, Itamar Syn-Hershko wrote:
When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi p...@colourbox.com wrote:
Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:
What is the exact URLs you're approaching? Are you specifying the index name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi p...@colourbox.com wrote:
Hi

We have a single machine elastic search server (8 shards but all hosted at the same machine). Index contains 7 million documents. We do not specify any custom routing when indexing the documents. We are using Elastic search version 1.2.

The problem is that we are unable to retrieve many of our documents using GET
, . However using search?_id: we are able to retrieve all of those documents.

We are also successful in retrieving a document by specifying routing parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that problem.

Any suggestions for resolution?

Thanks in advance

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/40eec5a2-55b2-4841-8618-dd54711d1062%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7166fa5a-6182-49ae-9666-28fb2fa43da2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53834268.419ac241.1e56%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Pir Abdul Rasool Qureshi) #11

No, We are not using any routing at all.
Secondly, I tried to reproduce it by adding some new documents and then
using GET. However, I am not yet successful in reproducing the issue.

For newer documents, GET works in an expected manner.

Thanks

On Mon, May 26, 2014 at 3:32 PM, David Pilato david@pilato.fr wrote:

Are you sure you are not using any routing value when indexing?

If so, could you recreate a curl/Sense recreation which reproduce the
problem?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 26 mai 2014 à 15:30:43, Pir Abdul Rasool Qureshi (pir@colourbox.com) a
écrit:

{
"OurIndex": {
"mappings": {
"OurType": {
"properties": {
"added": {
"type": "date",
"format": "dateOptionalTime"
},
"adult_content": {
"type": "boolean"
},
"bucket_id": {
"type": "short"
},
"company_id": {
"type": "long"
},
"created": {
"type": "date",
"format": "dateOptionalTime"
},
"da_keywords_1": {
"type": "string"
},
"da_keywords_2": {
"type": "string"
},
"da_keywords_3": {
"type": "string"
},
"da_keywords_4": {
"type": "string"
},
"da_keywords_5": {
"type": "string"
},
"da_text_keywords_1": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_2": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_3": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_4": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_5": {
"type": "string",
"analyzer": "danish"
},
"da_text_title": {
"type": "string",
"analyzer": "danish"
},
"da_title": {
"type": "string"
},
"de_keywords_1": {
"type": "string"
},
"de_keywords_2": {
"type": "string"
},
"de_keywords_3": {
"type": "string"
},
"de_keywords_4": {
"type": "string"
},
"de_keywords_5": {
"type": "string"
},
"de_text_keywords_1": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_2": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_3": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_4": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_5": {
"type": "string",
"analyzer": "german"
},
"de_text_title": {
"type": "string",
"analyzer": "german"
},
"de_title": {
"type": "string"
},
"dimension": {
"type": "string"
},
"duration": {
"type": "integer"
},
"editorial": {
"type": "string"
},
"en_keywords_1": {
"type": "string"
},
"en_keywords_2": {
"type": "string"
},
"en_keywords_3": {
"type": "string"
},
"en_keywords_4": {
"type": "string"
},
"en_keywords_5": {
"type": "string"
},
"en_text_keywords_1": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_2": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_3": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_4": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_5": {
"type": "string",
"analyzer": "english"
},
"en_text_title": {
"type": "string",
"analyzer": "english"
},
"en_title": {
"type": "string"
},
"folder_ids": {
"type": "long"
},
"height": {
"type": "integer"
},
"id": {
"type": "string"
},
"f_id": {
"type": "long"
},
"media_type": {
"type": "string"
},
"orientation": {
"type": "string"
},
"published": {
"type": "date",
"format": "dateOptionalTime"
},
"resolution": {
"type": "string"
},
"status": {
"type": "string"
},
"supplier_id": {
"type": "long"
},
"db_id": {
"type": "long"
},
"width": {
"type": "integer"
}
}
}
}
}
}

On Monday, May 26, 2014 3:09:18 PM UTC+2, David Pilato wrote:

What is your mapping?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 14:59, Pir Abdul Rasool Qureshi p...@colourbox.com a
écrit :

No, We are not using Parent/Child.

On Monday, May 26, 2014 1:54:11 PM UTC+2, David Pilato wrote:

Are you using parent child ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 13:50, Pir Abdul Rasool Qureshi p...@colourbox.com a
écrit :

It gives me the (expected) value i.e. 3624608.

Details:

Query 1:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/_
search?q=_id:3624608",
it retrieves a single document with _id = 3624608

Query 2:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/
3624608"
it results in
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"found": false
}

Query 3:

If I do curl -XGET "http://somehost:9200/OurIndex/OurType/3624608?
routing=1"
it retrieves a single document with _id = 3624608

Thanks

On Monday, May 26, 2014 12:14:26 PM UTC+2, Itamar Syn-Hershko wrote:

When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com> wrote:

Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:

What is the exact URLs you're approaching? Are you specifying the
index name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com> wrote:

Hi

We have a single machine elastic search server (8 shards but all
hosted at the same machine). Index contains 7 million documents. We do not
specify any custom routing when indexing the documents. We are using
Elastic search version 1.2.

The problem is that we are unable to retrieve many of our documents
using GET , . However using search?_id: we are able
to retrieve all of those documents.

We are also successful in retrieving a document by specifying
routing parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have
that problem.

Any suggestions for resolution?

Thanks in advance

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7
e-41c0-a1e9-538ef1565aba%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com?utm_medium=email&utm_source=footer.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/40eec5a2-55b2-4841-8618-dd54711d1062%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/40eec5a2-55b2-4841-8618-dd54711d1062%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7166fa5a-6182-49ae-9666-28fb2fa43da2%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/7166fa5a-6182-49ae-9666-28fb2fa43da2%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/9gqqqZrcXkc/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.53834268.419ac241.1e56%40MacBook-Air-de-David.local
https://groups.google.com/d/msgid/elasticsearch/etPan.53834268.419ac241.1e56%40MacBook-Air-de-David.local?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CADmyUWX_%2B8Q%3Dd%2B9BBWq5GJtJcXmekPmKS3-C00r1YCkGMnE3fw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #12

Could you send the result of: curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608&pretty"

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 26 mai 2014 à 15:42:37, Pir Abdul Rasool Qureshi (pir@colourbox.com) a écrit:

No, We are not using any routing at all.
Secondly, I tried to reproduce it by adding some new documents and then using GET. However, I am not yet successful in reproducing the issue.

For newer documents, GET works in an expected manner.

Thanks

On Mon, May 26, 2014 at 3:32 PM, David Pilato david@pilato.fr wrote:
Are you sure you are not using any routing value when indexing?

If so, could you recreate a curl/Sense recreation which reproduce the problem?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 26 mai 2014 à 15:30:43, Pir Abdul Rasool Qureshi (pir@colourbox.com) a écrit:

{
"OurIndex": {
"mappings": {
"OurType": {
"properties": {
"added": {
"type": "date",
"format": "dateOptionalTime"
},
"adult_content": {
"type": "boolean"
},
"bucket_id": {
"type": "short"
},
"company_id": {
"type": "long"
},
"created": {
"type": "date",
"format": "dateOptionalTime"
},
"da_keywords_1": {
"type": "string"
},
"da_keywords_2": {
"type": "string"
},
"da_keywords_3": {
"type": "string"
},
"da_keywords_4": {
"type": "string"
},
"da_keywords_5": {
"type": "string"
},
"da_text_keywords_1": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_2": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_3": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_4": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_5": {
"type": "string",
"analyzer": "danish"
},
"da_text_title": {
"type": "string",
"analyzer": "danish"
},
"da_title": {
"type": "string"
},
"de_keywords_1": {
"type": "string"
},
"de_keywords_2": {
"type": "string"
},
"de_keywords_3": {
"type": "string"
},
"de_keywords_4": {
"type": "string"
},
"de_keywords_5": {
"type": "string"
},
"de_text_keywords_1": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_2": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_3": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_4": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_5": {
"type": "string",
"analyzer": "german"
},
"de_text_title": {
"type": "string",
"analyzer": "german"
},
"de_title": {
"type": "string"
},
"dimension": {
"type": "string"
},
"duration": {
"type": "integer"
},
"editorial": {
"type": "string"
},
"en_keywords_1": {
"type": "string"
},
"en_keywords_2": {
"type": "string"
},
"en_keywords_3": {
"type": "string"
},
"en_keywords_4": {
"type": "string"
},
"en_keywords_5": {
"type": "string"
},
"en_text_keywords_1": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_2": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_3": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_4": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_5": {
"type": "string",
"analyzer": "english"
},
"en_text_title": {
"type": "string",
"analyzer": "english"
},
"en_title": {
"type": "string"
},
"folder_ids": {
"type": "long"
},
"height": {
"type": "integer"
},
"id": {
"type": "string"
},
"f_id": {
"type": "long"
},
"media_type": {
"type": "string"
},
"orientation": {
"type": "string"
},
"published": {
"type": "date",
"format": "dateOptionalTime"
},
"resolution": {
"type": "string"
},
"status": {
"type": "string"
},
"supplier_id": {
"type": "long"
},
"db_id": {
"type": "long"
},
"width": {
"type": "integer"
}
}
}
}
}
}

On Monday, May 26, 2014 3:09:18 PM UTC+2, David Pilato wrote:
What is your mapping?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 14:59, Pir Abdul Rasool Qureshi p...@colourbox.com a écrit :

No, We are not using Parent/Child.

On Monday, May 26, 2014 1:54:11 PM UTC+2, David Pilato wrote:
Are you using parent child ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 13:50, Pir Abdul Rasool Qureshi p...@colourbox.com a écrit :

It gives me the (expected) value i.e. 3624608.

Details:

Query 1:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608",
it retrieves a single document with _id = 3624608

Query 2:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/3624608"
it results in
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"found": false
}

Query 3:

If I do curl -XGET "http://somehost:9200/OurIndex/OurType/3624608?routing=1"
it retrieves a single document with _id = 3624608

Thanks

On Monday, May 26, 2014 12:14:26 PM UTC+2, Itamar Syn-Hershko wrote:
When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi p...@colourbox.com wrote:
Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:
What is the exact URLs you're approaching? Are you specifying the index name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi p...@colourbox.com wrote:
Hi

We have a single machine elastic search server (8 shards but all hosted at the same machine). Index contains 7 million documents. We do not specify any custom routing when indexing the documents. We are using Elastic search version 1.2.

The problem is that we are unable to retrieve many of our documents using GET
, . However using search?_id: we are able to retrieve all of those documents.

We are also successful in retrieving a document by specifying routing parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that problem.

Any suggestions for resolution?

Thanks in advance

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/40eec5a2-55b2-4841-8618-dd54711d1062%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7166fa5a-6182-49ae-9666-28fb2fa43da2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/9gqqqZrcXkc/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53834268.419ac241.1e56%40MacBook-Air-de-David.local.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CADmyUWX_%2B8Q%3Dd%2B9BBWq5GJtJcXmekPmKS3-C00r1YCkGMnE3fw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53834558.2463b9ea.1e56%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Pir Abdul Rasool Qureshi) #13

{
"took": 1,
"timed_out": false,
"_shards": {
"total": 8,
"successful": 8,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"_score": 1,
"_source": {
"f_id": "3649288",
"db_id": "3624608",
"company_id": "2",
"supplier_id": "6100",
"editorial": false,
"adult_content": false,
"duration": null,
"status": "released",
"bucket_id": "4",
"width": "2250",
"height": "3000",
"orientation": "vertical",
"resolution": "other",
"dimension": "2250X3000",
"created": "2012-03-14T21:22:08Z",
"added": "2012-03-14T22:22:08Z",
"published": "2012-03-14T22:23:56Z",
"media_type": "image",
"folder_ids": [
1
],
"id": "3624608",
"en_keywords_5": [
"concept",
}
}
]
}
}

On Mon, May 26, 2014 at 3:44 PM, David Pilato david@pilato.fr wrote:

Could you send the result of: curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608
&pretty"

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 26 mai 2014 à 15:42:37, Pir Abdul Rasool Qureshi (pir@colourbox.com) a
écrit:

No, We are not using any routing at all.
Secondly, I tried to reproduce it by adding some new documents and then
using GET. However, I am not yet successful in reproducing the issue.

For newer documents, GET works in an expected manner.

Thanks

On Mon, May 26, 2014 at 3:32 PM, David Pilato david@pilato.fr wrote:

Are you sure you are not using any routing value when indexing?

If so, could you recreate a curl/Sense recreation which reproduce the
problem?

 --

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 26 mai 2014 à 15:30:43, Pir Abdul Rasool Qureshi (pir@colourbox.com)
a écrit:

{
"OurIndex": {
"mappings": {
"OurType": {
"properties": {
"added": {
"type": "date",
"format": "dateOptionalTime"
},
"adult_content": {
"type": "boolean"
},
"bucket_id": {
"type": "short"
},
"company_id": {
"type": "long"
},
"created": {
"type": "date",
"format": "dateOptionalTime"
},
"da_keywords_1": {
"type": "string"
},
"da_keywords_2": {
"type": "string"
},
"da_keywords_3": {
"type": "string"
},
"da_keywords_4": {
"type": "string"
},
"da_keywords_5": {
"type": "string"
},
"da_text_keywords_1": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_2": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_3": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_4": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_5": {
"type": "string",
"analyzer": "danish"
},
"da_text_title": {
"type": "string",
"analyzer": "danish"
},
"da_title": {
"type": "string"
},
"de_keywords_1": {
"type": "string"
},
"de_keywords_2": {
"type": "string"
},
"de_keywords_3": {
"type": "string"
},
"de_keywords_4": {
"type": "string"
},
"de_keywords_5": {
"type": "string"
},
"de_text_keywords_1": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_2": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_3": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_4": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_5": {
"type": "string",
"analyzer": "german"
},
"de_text_title": {
"type": "string",
"analyzer": "german"
},
"de_title": {
"type": "string"
},
"dimension": {
"type": "string"
},
"duration": {
"type": "integer"
},
"editorial": {
"type": "string"
},
"en_keywords_1": {
"type": "string"
},
"en_keywords_2": {
"type": "string"
},
"en_keywords_3": {
"type": "string"
},
"en_keywords_4": {
"type": "string"
},
"en_keywords_5": {
"type": "string"
},
"en_text_keywords_1": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_2": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_3": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_4": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_5": {
"type": "string",
"analyzer": "english"
},
"en_text_title": {
"type": "string",
"analyzer": "english"
},
"en_title": {
"type": "string"
},
"folder_ids": {
"type": "long"
},
"height": {
"type": "integer"
},
"id": {
"type": "string"
},
"f_id": {
"type": "long"
},
"media_type": {
"type": "string"
},
"orientation": {
"type": "string"
},
"published": {
"type": "date",
"format": "dateOptionalTime"
},
"resolution": {
"type": "string"
},
"status": {
"type": "string"
},
"supplier_id": {
"type": "long"
},
"db_id": {
"type": "long"
},
"width": {
"type": "integer"
}
}
}
}
}
}

On Monday, May 26, 2014 3:09:18 PM UTC+2, David Pilato wrote:

What is your mapping?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 14:59, Pir Abdul Rasool Qureshi p...@colourbox.com a
écrit :

No, We are not using Parent/Child.

On Monday, May 26, 2014 1:54:11 PM UTC+2, David Pilato wrote:

Are you using parent child ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 13:50, Pir Abdul Rasool Qureshi p...@colourbox.com
a écrit :

It gives me the (expected) value i.e. 3624608.

Details:

Query 1:

If I do curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608",
it retrieves a single document with _id = 3624608

Query 2:

If I do curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/3624608"
it results in
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"found": false
}

Query 3:

If I do curl -XGET "
http://somehost:9200/OurIndex/OurType/3624608?routing=1"
it retrieves a single document with _id = 3624608

Thanks

On Monday, May 26, 2014 12:14:26 PM UTC+2, Itamar Syn-Hershko wrote:

When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com> wrote:

Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:

What is the exact URLs you're approaching? Are you specifying the
index name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com> wrote:

Hi

We have a single machine elastic search server (8 shards but all
hosted at the same machine). Index contains 7 million documents. We do not
specify any custom routing when indexing the documents. We are using
Elastic search version 1.2.

The problem is that we are unable to retrieve many of our documents
using GET , . However using search?_id: we are
able to retrieve all of those documents.

We are also successful in retrieving a document by specifying
routing parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have
that problem.

Any suggestions for resolution?

Thanks in advance

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com?utm_medium=email&utm_source=footer.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/40eec5a2-55b2-4841-8618-dd54711d1062%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/40eec5a2-55b2-4841-8618-dd54711d1062%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7166fa5a-6182-49ae-9666-28fb2fa43da2%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/7166fa5a-6182-49ae-9666-28fb2fa43da2%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/9gqqqZrcXkc/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.53834268.419ac241.1e56%40MacBook-Air-de-David.local
https://groups.google.com/d/msgid/elasticsearch/etPan.53834268.419ac241.1e56%40MacBook-Air-de-David.local?utm_medium=email&utm_source=footer.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CADmyUWX_%2B8Q%3Dd%2B9BBWq5GJtJcXmekPmKS3-C00r1YCkGMnE3fw%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CADmyUWX_%2B8Q%3Dd%2B9BBWq5GJtJcXmekPmKS3-C00r1YCkGMnE3fw%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/9gqqqZrcXkc/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.53834558.2463b9ea.1e56%40MacBook-Air-de-David.local
https://groups.google.com/d/msgid/elasticsearch/etPan.53834558.2463b9ea.1e56%40MacBook-Air-de-David.local?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CADmyUWWYiG7%3DgAebrERZHP8i83qwmpJKMXwUeRQRjsvv87Vg9g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #14

And this?

curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608&pretty&fields=_routing"

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 26 mai 2014 à 15:49:00, Pir Abdul Rasool Qureshi (pir@colourbox.com) a écrit:

{
"took": 1,
"timed_out": false,
"_shards": {
"total": 8,
"successful": 8,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"_score": 1,
"_source": {
"f_id": "3649288",
"db_id": "3624608",
"company_id": "2",
"supplier_id": "6100",
"editorial": false,
"adult_content": false,
"duration": null,
"status": "released",
"bucket_id": "4",
"width": "2250",
"height": "3000",
"orientation": "vertical",
"resolution": "other",
"dimension": "2250X3000",
"created": "2012-03-14T21:22:08Z",
"added": "2012-03-14T22:22:08Z",
"published": "2012-03-14T22:23:56Z",
"media_type": "image",
"folder_ids": [
1
],
"id": "3624608",
"en_keywords_5": [
"concept",
}
}
]
}
}

On Mon, May 26, 2014 at 3:44 PM, David Pilato david@pilato.fr wrote:
Could you send the result of: curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608&pretty"

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 26 mai 2014 à 15:42:37, Pir Abdul Rasool Qureshi (pir@colourbox.com) a écrit:

No, We are not using any routing at all.
Secondly, I tried to reproduce it by adding some new documents and then using GET. However, I am not yet successful in reproducing the issue.

For newer documents, GET works in an expected manner.

Thanks

On Mon, May 26, 2014 at 3:32 PM, David Pilato david@pilato.fr wrote:
Are you sure you are not using any routing value when indexing?

If so, could you recreate a curl/Sense recreation which reproduce the problem?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 26 mai 2014 à 15:30:43, Pir Abdul Rasool Qureshi (pir@colourbox.com) a écrit:

{
"OurIndex": {
"mappings": {
"OurType": {
"properties": {
"added": {
"type": "date",
"format": "dateOptionalTime"
},
"adult_content": {
"type": "boolean"
},
"bucket_id": {
"type": "short"
},
"company_id": {
"type": "long"
},
"created": {
"type": "date",
"format": "dateOptionalTime"
},
"da_keywords_1": {
"type": "string"
},
"da_keywords_2": {
"type": "string"
},
"da_keywords_3": {
"type": "string"
},
"da_keywords_4": {
"type": "string"
},
"da_keywords_5": {
"type": "string"
},
"da_text_keywords_1": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_2": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_3": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_4": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_5": {
"type": "string",
"analyzer": "danish"
},
"da_text_title": {
"type": "string",
"analyzer": "danish"
},
"da_title": {
"type": "string"
},
"de_keywords_1": {
"type": "string"
},
"de_keywords_2": {
"type": "string"
},
"de_keywords_3": {
"type": "string"
},
"de_keywords_4": {
"type": "string"
},
"de_keywords_5": {
"type": "string"
},
"de_text_keywords_1": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_2": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_3": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_4": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_5": {
"type": "string",
"analyzer": "german"
},
"de_text_title": {
"type": "string",
"analyzer": "german"
},
"de_title": {
"type": "string"
},
"dimension": {
"type": "string"
},
"duration": {
"type": "integer"
},
"editorial": {
"type": "string"
},
"en_keywords_1": {
"type": "string"
},
"en_keywords_2": {
"type": "string"
},
"en_keywords_3": {
"type": "string"
},
"en_keywords_4": {
"type": "string"
},
"en_keywords_5": {
"type": "string"
},
"en_text_keywords_1": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_2": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_3": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_4": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_5": {
"type": "string",
"analyzer": "english"
},
"en_text_title": {
"type": "string",
"analyzer": "english"
},
"en_title": {
"type": "string"
},
"folder_ids": {
"type": "long"
},
"height": {
"type": "integer"
},
"id": {
"type": "string"
},
"f_id": {
"type": "long"
},
"media_type": {
"type": "string"
},
"orientation": {
"type": "string"
},
"published": {
"type": "date",
"format": "dateOptionalTime"
},
"resolution": {
"type": "string"
},
"status": {
"type": "string"
},
"supplier_id": {
"type": "long"
},
"db_id": {
"type": "long"
},
"width": {
"type": "integer"
}
}
}
}
}
}

On Monday, May 26, 2014 3:09:18 PM UTC+2, David Pilato wrote:
What is your mapping?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 14:59, Pir Abdul Rasool Qureshi p...@colourbox.com a écrit :

No, We are not using Parent/Child.

On Monday, May 26, 2014 1:54:11 PM UTC+2, David Pilato wrote:
Are you using parent child ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 13:50, Pir Abdul Rasool Qureshi p...@colourbox.com a écrit :

It gives me the (expected) value i.e. 3624608.

Details:

Query 1:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608",
it retrieves a single document with _id = 3624608

Query 2:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/3624608"
it results in
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"found": false
}

Query 3:

If I do curl -XGET "http://somehost:9200/OurIndex/OurType/3624608?routing=1"
it retrieves a single document with _id = 3624608

Thanks

On Monday, May 26, 2014 12:14:26 PM UTC+2, Itamar Syn-Hershko wrote:
When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi p...@colourbox.com wrote:
Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:
What is the exact URLs you're approaching? Are you specifying the index name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi p...@colourbox.com wrote:
Hi

We have a single machine elastic search server (8 shards but all hosted at the same machine). Index contains 7 million documents. We do not specify any custom routing when indexing the documents. We are using Elastic search version 1.2.

The problem is that we are unable to retrieve many of our documents using GET
, . However using search?_id: we are able to retrieve all of those documents.

We are also successful in retrieving a document by specifying routing parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that problem.

Any suggestions for resolution?

Thanks in advance

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/414ce221-e287-47b9-ab4b-d791a6e3983b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/40eec5a2-55b2-4841-8618-dd54711d1062%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7166fa5a-6182-49ae-9666-28fb2fa43da2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/9gqqqZrcXkc/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53834268.419ac241.1e56%40MacBook-Air-de-David.local.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CADmyUWX_%2B8Q%3Dd%2B9BBWq5GJtJcXmekPmKS3-C00r1YCkGMnE3fw%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/9gqqqZrcXkc/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53834558.2463b9ea.1e56%40MacBook-Air-de-David.local.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CADmyUWWYiG7%3DgAebrERZHP8i83qwmpJKMXwUeRQRjsvv87Vg9g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53834cd0.580bd78f.1e56%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Pir Abdul Rasool Qureshi) #15

{
"took": 1,
"timed_out": false,
"_shards": {
"total": 8,
"successful": 8,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"_score": 1
}
]
}
}

On Monday, May 26, 2014 4:17:03 PM UTC+2, David Pilato wrote:

And this?

curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608&pretty&fields=_routing
"

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 26 mai 2014 à 15:49:00, Pir Abdul Rasool Qureshi (p...@colourbox.com<javascript:>)
a écrit:

{
"took": 1,
"timed_out": false,
"_shards": {
"total": 8,
"successful": 8,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"_score": 1,
"_source": {
"f_id": "3649288",
"db_id": "3624608",
"company_id": "2",
"supplier_id": "6100",
"editorial": false,
"adult_content": false,
"duration": null,
"status": "released",
"bucket_id": "4",
"width": "2250",
"height": "3000",
"orientation": "vertical",
"resolution": "other",
"dimension": "2250X3000",
"created": "2012-03-14T21:22:08Z",
"added": "2012-03-14T22:22:08Z",
"published": "2012-03-14T22:23:56Z",
"media_type": "image",
"folder_ids": [
1
],
"id": "3624608",
"en_keywords_5": [
"concept",
}
}
]
}
}

On Mon, May 26, 2014 at 3:44 PM, David Pilato <da...@pilato.fr<javascript:>

wrote:

Could you send the result of: curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608
&pretty"

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 26 mai 2014 à 15:42:37, Pir Abdul Rasool Qureshi (p...@colourbox.com<javascript:>)
a écrit:

No, We are not using any routing at all.
Secondly, I tried to reproduce it by adding some new documents and then
using GET. However, I am not yet successful in reproducing the issue.

For newer documents, GET works in an expected manner.

Thanks

On Mon, May 26, 2014 at 3:32 PM, David Pilato <da...@pilato.fr<javascript:>

wrote:

Are you sure you are not using any routing value when indexing?

If so, could you recreate a curl/Sense recreation which reproduce the
problem?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 26 mai 2014 à 15:30:43, Pir Abdul Rasool Qureshi (p...@colourbox.com<javascript:>)
a écrit:

{
"OurIndex": {
"mappings": {
"OurType": {
"properties": {
"added": {
"type": "date",
"format": "dateOptionalTime"
},
"adult_content": {
"type": "boolean"
},
"bucket_id": {
"type": "short"
},
"company_id": {
"type": "long"
},
"created": {
"type": "date",
"format": "dateOptionalTime"
},
"da_keywords_1": {
"type": "string"
},
"da_keywords_2": {
"type": "string"
},
"da_keywords_3": {
"type": "string"
},
"da_keywords_4": {
"type": "string"
},
"da_keywords_5": {
"type": "string"
},
"da_text_keywords_1": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_2": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_3": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_4": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_5": {
"type": "string",
"analyzer": "danish"
},
"da_text_title": {
"type": "string",
"analyzer": "danish"
},
"da_title": {
"type": "string"
},
"de_keywords_1": {
"type": "string"
},
"de_keywords_2": {
"type": "string"
},
"de_keywords_3": {
"type": "string"
},
"de_keywords_4": {
"type": "string"
},
"de_keywords_5": {
"type": "string"
},
"de_text_keywords_1": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_2": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_3": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_4": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_5": {
"type": "string",
"analyzer": "german"
},
"de_text_title": {
"type": "string",
"analyzer": "german"
},
"de_title": {
"type": "string"
},
"dimension": {
"type": "string"
},
"duration": {
"type": "integer"
},
"editorial": {
"type": "string"
},
"en_keywords_1": {
"type": "string"
},
"en_keywords_2": {
"type": "string"
},
"en_keywords_3": {
"type": "string"
},
"en_keywords_4": {
"type": "string"
},
"en_keywords_5": {
"type": "string"
},
"en_text_keywords_1": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_2": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_3": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_4": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_5": {
"type": "string",
"analyzer": "english"
},
"en_text_title": {
"type": "string",
"analyzer": "english"
},
"en_title": {
"type": "string"
},
"folder_ids": {
"type": "long"
},
"height": {
"type": "integer"
},
"id": {
"type": "string"
},
"f_id": {
"type": "long"
},
"media_type": {
"type": "string"
},
"orientation": {
"type": "string"
},
"published": {
"type": "date",
"format": "dateOptionalTime"
},
"resolution": {
"type": "string"
},
"status": {
"type": "string"
},
"supplier_id": {
"type": "long"
},
"db_id": {
"type": "long"
},
"width": {
"type": "integer"
}
}
}
}
}
}

On Monday, May 26, 2014 3:09:18 PM UTC+2, David Pilato wrote:

What is your mapping?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 14:59, Pir Abdul Rasool Qureshi p...@colourbox.com a
écrit :

No, We are not using Parent/Child.

On Monday, May 26, 2014 1:54:11 PM UTC+2, David Pilato wrote:

Are you using parent child ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 13:50, Pir Abdul Rasool Qureshi p...@colourbox.com a
écrit :

It gives me the (expected) value i.e. 3624608.

Details:

Query 1:

If I do curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608",
it retrieves a single document with _id = 3624608

Query 2:

If I do curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/3624608"
it results in
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"found": false
}

Query 3:

If I do curl -XGET "
http://somehost:9200/OurIndex/OurType/3624608?routing=1"
it retrieves a single document with _id = 3624608

Thanks

On Monday, May 26, 2014 12:14:26 PM UTC+2, Itamar Syn-Hershko wrote:

When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com> wrote:

Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:

What is the exact URLs you're approaching? Are you specifying the index
name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi <
p...@colourbox.com> wrote:

Hi

We have a single machine elastic search server (8 shards but all hosted at
the same machine). Index contains 7 million documents. We do not specify
any custom routing when indexing the documents. We are using Elastic search
version 1.2.

The problem is that we are unable to retrieve many of our documents using GET
, . However using search?_id: we are able to retrieve all
of those documents.

We are also successful in retrieving a document by specifying routing
parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that
problem.

Any suggestions for resolution?

Thanks in advance

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com?utm_medium=email&utm_source=footer.

For more options, visit https://groups.google.com/d/optout.

<b

...

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c89bd653-1adb-44a0-8c62-6a09620843ba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #16

I can't find a good explanation here.
Did you update any setting at some point? Update elasticsearch? Added a plugin?

The way we assign shard for a document is:

  • using parent shard when using parent/child feature
  • using routing value if given
  • using document id

It sounds like you are using the 3rd option (default). So, the document should go to the same exact shard at index time as the one we get the document back at GET time.

If you could find or recall any operation you did, it would help.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 27 mai 2014 à 08:50:23, Pir Abdul Rasool Qureshi (pir@colourbox.com) a écrit:

{
"took": 1,
"timed_out": false,
"_shards": {
"total": 8,
"successful": 8,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"_score": 1
}
]
}
}

On Monday, May 26, 2014 4:17:03 PM UTC+2, David Pilato wrote:
And this?

curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608&pretty&fields=_routing"

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 26 mai 2014 à 15:49:00, Pir Abdul Rasool Qureshi (p...@colourbox.com) a écrit:

{
"took": 1,
"timed_out": false,
"_shards": {
"total": 8,
"successful": 8,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"_score": 1,
"_source": {
"f_id": "3649288",
"db_id": "3624608",
"company_id": "2",
"supplier_id": "6100",
"editorial": false,
"adult_content": false,
"duration": null,
"status": "released",
"bucket_id": "4",
"width": "2250",
"height": "3000",
"orientation": "vertical",
"resolution": "other",
"dimension": "2250X3000",
"created": "2012-03-14T21:22:08Z",
"added": "2012-03-14T22:22:08Z",
"published": "2012-03-14T22:23:56Z",
"media_type": "image",
"folder_ids": [
1
],
"id": "3624608",
"en_keywords_5": [
"concept",
}
}
]
}
}

On Mon, May 26, 2014 at 3:44 PM, David Pilato da...@pilato.fr wrote:
Could you send the result of: curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608&pretty"

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 26 mai 2014 à 15:42:37, Pir Abdul Rasool Qureshi (p...@colourbox.com) a écrit:

No, We are not using any routing at all.
Secondly, I tried to reproduce it by adding some new documents and then using GET. However, I am not yet successful in reproducing the issue.

For newer documents, GET works in an expected manner.

Thanks

On Mon, May 26, 2014 at 3:32 PM, David Pilato da...@pilato.fr wrote:
Are you sure you are not using any routing value when indexing?

If so, could you recreate a curl/Sense recreation which reproduce the problem?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 26 mai 2014 à 15:30:43, Pir Abdul Rasool Qureshi (p...@colourbox.com) a écrit:

{
"OurIndex": {
"mappings": {
"OurType": {
"properties": {
"added": {
"type": "date",
"format": "dateOptionalTime"
},
"adult_content": {
"type": "boolean"
},
"bucket_id": {
"type": "short"
},
"company_id": {
"type": "long"
},
"created": {
"type": "date",
"format": "dateOptionalTime"
},
"da_keywords_1": {
"type": "string"
},
"da_keywords_2": {
"type": "string"
},
"da_keywords_3": {
"type": "string"
},
"da_keywords_4": {
"type": "string"
},
"da_keywords_5": {
"type": "string"
},
"da_text_keywords_1": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_2": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_3": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_4": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_5": {
"type": "string",
"analyzer": "danish"
},
"da_text_title": {
"type": "string",
"analyzer": "danish"
},
"da_title": {
"type": "string"
},
"de_keywords_1": {
"type": "string"
},
"de_keywords_2": {
"type": "string"
},
"de_keywords_3": {
"type": "string"
},
"de_keywords_4": {
"type": "string"
},
"de_keywords_5": {
"type": "string"
},
"de_text_keywords_1": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_2": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_3": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_4": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_5": {
"type": "string",
"analyzer": "german"
},
"de_text_title": {
"type": "string",
"analyzer": "german"
},
"de_title": {
"type": "string"
},
"dimension": {
"type": "string"
},
"duration": {
"type": "integer"
},
"editorial": {
"type": "string"
},
"en_keywords_1": {
"type": "string"
},
"en_keywords_2": {
"type": "string"
},
"en_keywords_3": {
"type": "string"
},
"en_keywords_4": {
"type": "string"
},
"en_keywords_5": {
"type": "string"
},
"en_text_keywords_1": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_2": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_3": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_4": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_5": {
"type": "string",
"analyzer": "english"
},
"en_text_title": {
"type": "string",
"analyzer": "english"
},
"en_title": {
"type": "string"
},
"folder_ids": {
"type": "long"
},
"height": {
"type": "integer"
},
"id": {
"type": "string"
},
"f_id": {
"type": "long"
},
"media_type": {
"type": "string"
},
"orientation": {
"type": "string"
},
"published": {
"type": "date",
"format": "dateOptionalTime"
},
"resolution": {
"type": "string"
},
"status": {
"type": "string"
},
"supplier_id": {
"type": "long"
},
"db_id": {
"type": "long"
},
"width": {
"type": "integer"
}
}
}
}
}
}

On Monday, May 26, 2014 3:09:18 PM UTC+2, David Pilato wrote:
What is your mapping?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 14:59, Pir Abdul Rasool Qureshi p...@colourbox.com a écrit :

No, We are not using Parent/Child.

On Monday, May 26, 2014 1:54:11 PM UTC+2, David Pilato wrote:
Are you using parent child ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 mai 2014 à 13:50, Pir Abdul Rasool Qureshi p...@colourbox.com a écrit :

It gives me the (expected) value i.e. 3624608.

Details:

Query 1:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608",
it retrieves a single document with _id = 3624608

Query 2:

If I do curl -XGET "http://somehost:9200/colourbox/OurIndex/OurType/3624608"
it results in
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"found": false
}

Query 3:

If I do curl -XGET "http://somehost:9200/OurIndex/OurType/3624608?routing=1"
it retrieves a single document with _id = 3624608

Thanks

On Monday, May 26, 2014 12:14:26 PM UTC+2, Itamar Syn-Hershko wrote:
When you search, what does the _id field of the result indicate?

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, May 26, 2014 at 11:32 AM, Pir Abdul Rasool Qureshi p...@colourbox.com wrote:
Yes we are specifying index name and type in urls.
The curl request looks like the following,

curl -XGET "http://somehost:9200/OurIndex/OurType/3624608"

where 3624608 is id of the document

Thanks

On Monday, May 26, 2014 9:49:33 AM UTC+2, Itamar Syn-Hershko wrote:
What is the exact URLs you're approaching? Are you specifying the index name and type name as well in your GET ?

--

Itamar Syn-Hershko
http://code972.com | @synhershko
Freelance Developer & Consultant
Author of RavenDB in Action

On Mon, May 26, 2014 at 10:47 AM, Pir Abdul Rasool Qureshi p...@colourbox.com wrote:
Hi

We have a single machine elastic search server (8 shards but all hosted at the same machine). Index contains 7 million documents. We do not specify any custom routing when indexing the documents. We are using Elastic search version 1.2.

The problem is that we are unable to retrieve many of our documents using GET
, . However using search?_id: we are able to retrieve all of those documents.

We are also successful in retrieving a document by specifying routing parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that problem.

Any suggestions for resolution?

Thanks in advance

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d27e9ca7-4f7e-41c0-a1e9-538ef1565aba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/696d57ae-2c89-4de0-8269-4abed03ba15f%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.
<b
...

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c89bd653-1adb-44a0-8c62-6a09620843ba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53844a21.579478fe.1e56%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Pir Abdul Rasool Qureshi) #17

No change has been made to settings. It is like we were running version
1.0.3 without any issues. We prepared another machine with Elastic Search
to 1.2. Re-indexed all of the data.
After that the issue started to appear.

I am thinking of creating new index and re-indexing the data again, any
suggestions?

On Tuesday, May 27, 2014 10:17:48 AM UTC+2, David Pilato wrote:

I can't find a good explanation here.
Did you update any setting at some point? Update elasticsearch? Added a
plugin?

The way we assign shard for a document is:

  • using parent shard when using parent/child feature
  • using routing value if given
  • using document id

It sounds like you are using the 3rd option (default). So, the document
should go to the same exact shard at index time as the one we get the
document back at GET time.

If you could find or recall any operation you did, it would help.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 27 mai 2014 à 08:50:23, Pir Abdul Rasool Qureshi (p...@colourbox.com<javascript:>)
a écrit:

{
"took": 1,
"timed_out": false,
"_shards": {
"total": 8,
"successful": 8,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"_score": 1
}
]
}
}

On Monday, May 26, 2014 4:17:03 PM UTC+2, David Pilato wrote:

And this?

curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608&pretty&fields=_routing
"

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 26 mai 2014 à 15:49:00, Pir Abdul Rasool Qureshi (p...@colourbox.com)
a écrit:

{
"took": 1,
"timed_out": false,
"_shards": {
"total": 8,
"successful": 8,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"_score": 1,
"_source": {
"f_id": "3649288",
"db_id": "3624608",
"company_id": "2",
"supplier_id": "6100",
"editorial": false,
"adult_content": false,
"duration": null,
"status": "released",
"bucket_id": "4",
"width": "2250",
"height": "3000",
"orientation": "vertical",
"resolution": "other",
"dimension": "2250X3000",
"created": "2012-03-14T21:22:08Z",
"added": "2012-03-14T22:22:08Z",
"published": "2012-03-14T22:23:56Z",
"media_type": "image",
"folder_ids": [
1
],
"id": "3624608",
"en_keywords_5": [
"concept",
}
}
]
}
}

On Mon, May 26, 2014 at 3:44 PM, David Pilato da...@pilato.fr wrote:

Could you send the result of: curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608
&pretty"

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 26 mai 2014 à 15:42:37, Pir Abdul Rasool Qureshi (p...@colourbox.com)
a écrit:

No, We are not using any routing at all.
Secondly, I tried to reproduce it by adding some new documents and then
using GET. However, I am not yet successful in reproducing the issue.

For newer documents, GET works in an expected manner.

Thanks

On Mon, May 26, 2014 at 3:32 PM, David Pilato da...@pilato.fr wrote:

Are you sure you are not using any routing value when indexing?

If so, could you recreate a curl/Sense recreation which reproduce the
problem?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 26 mai 2014 à 15:30:43, Pir Abdul Rasool Qureshi (p...@colourbox.com)
a écrit:

{
"OurIndex": {
"mappings": {
"OurType": {
"properties": {
"added": {
"type": "date",
"format": "dateOptionalTime"
},
"adult_content": {
"type": "boolean"
},
"bucket_id": {
"type": "short"
},
"company_id": {
"type": "long"
},
"created": {
"type": "date",
"format": "dateOptionalTime"
},
"da_keywords_1": {
"type": "string"
},
"da_keywords_2": {
"type": "string"
},
"da_keywords_3": {
"type": "string"
},
"da_keywords_4": {
"type": "string"
},
"da_keywords_5": {
"type": "string"
},
"da_text_keywords_1": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_2": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_3": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_4": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_5": {
"type": "string",
"analyzer": "danish"
},
"da_text_title": {
"type": "string",
"analyzer": "danish"
},
"da_title": {
"type": "string"
},
"de_keywords_1": {
"type": "string"
},
"de_keywords_2": {
"type": "string"
},
"de_keywords_3": {
"type": "string"
},
"de_keywords_4": {
"type": "string"
},
"de_keywords_5": {
"type": "string"
},
"de_text_keywords_1": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_2": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_3": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_4": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_5": {
"type": "string",
"analyzer": "german"
},
"de_text_title": {
"type": "string",
"analyzer": "german"
},
"de_title": {
"type": "string"
},
"dimension": {
"type": "string"
},
"duration": {
"type": "integer"
},
"editorial": {
"type": "string"
},
"en_keywords_1": {
"type": "string"
},
"en_keywords_2": {
"type": "string"
},
"en_keywords_3": {
"type": "string"
},
"en_keywords_4": {
"type": "string"
},
"en_keywords_5": {
"type": "string"
},
"en_text_keywords_1": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_2": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_3": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_4": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_5": {
"type": "string",
"analyzer": "english"
},
"en_text_title": {
"type": "string",
"analyzer": "english"
},
"en_title": {
"type": "string"
},
"folder_ids": {
"type": "long"
},
"height": {
"type": "integer"
},
"id": {
"type": "string"
},
"f_id": {
"type": "long"
},
"media_type": {
"type": "string"
},
"orientation": {
"type": "string"
},
"published": {
"type": "date",
"format": "dateOptionalTime"
},
"resolution": {
"type": "string"
},
"status": {
"type": "string"
},
"supplier_id": {
"type": "long"
},
"db_id": {
"type": "long"
},
"width": {
"type": "integer"
}

...

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e8cb52c8-814b-4870-b21d-5f32bf36919e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Pir Abdul Rasool Qureshi) #18

Sorry, there was a mistake. We had all of the data in Elastic Search
version 1.1 and then we upgraded to Elastic Search 1.2 (We did not
re-indexed the data when we upgraded).

Thanks
Pir

On Tuesday, May 27, 2014 10:33:16 AM UTC+2, Pir Abdul Rasool Qureshi wrote:

No change has been made to settings. It is like we were running version
1.0.3 without any issues. We prepared another machine with Elastic Search
to 1.2. Re-indexed all of the data.
After that the issue started to appear.

I am thinking of creating new index and re-indexing the data again, any
suggestions?

On Tuesday, May 27, 2014 10:17:48 AM UTC+2, David Pilato wrote:

I can't find a good explanation here.
Did you update any setting at some point? Update elasticsearch? Added a
plugin?

The way we assign shard for a document is:

  • using parent shard when using parent/child feature
  • using routing value if given
  • using document id

It sounds like you are using the 3rd option (default). So, the document
should go to the same exact shard at index time as the one we get the
document back at GET time.

If you could find or recall any operation you did, it would help.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 27 mai 2014 à 08:50:23, Pir Abdul Rasool Qureshi (p...@colourbox.com)
a écrit:

{
"took": 1,
"timed_out": false,
"_shards": {
"total": 8,
"successful": 8,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"_score": 1
}
]
}
}

On Monday, May 26, 2014 4:17:03 PM UTC+2, David Pilato wrote:

And this?

curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608&pretty&fields=_routing
"

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 26 mai 2014 à 15:49:00, Pir Abdul Rasool Qureshi (p...@colourbox.com)
a écrit:

{
"took": 1,
"timed_out": false,
"_shards": {
"total": 8,
"successful": 8,
"failed": 0
},
"hits": {
"total": 1,
"max_score": 1,
"hits": [
{
"_index": "OurIndex",
"_type": "OurType",
"_id": "3624608",
"_score": 1,
"_source": {
"f_id": "3649288",
"db_id": "3624608",
"company_id": "2",
"supplier_id": "6100",
"editorial": false,
"adult_content": false,
"duration": null,
"status": "released",
"bucket_id": "4",
"width": "2250",
"height": "3000",
"orientation": "vertical",
"resolution": "other",
"dimension": "2250X3000",
"created": "2012-03-14T21:22:08Z",
"added": "2012-03-14T22:22:08Z",
"published": "2012-03-14T22:23:56Z",
"media_type": "image",
"folder_ids": [
1
],
"id": "3624608",
"en_keywords_5": [
"concept",
}
}
]
}
}

On Mon, May 26, 2014 at 3:44 PM, David Pilato da...@pilato.fr wrote:

Could you send the result of: curl -XGET "
http://somehost:9200/colourbox/OurIndex/OurType/_search?q=_id:3624608
&pretty"

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 26 mai 2014 à 15:42:37, Pir Abdul Rasool Qureshi (p...@colourbox.com)
a écrit:

No, We are not using any routing at all.
Secondly, I tried to reproduce it by adding some new documents and then
using GET. However, I am not yet successful in reproducing the issue.

For newer documents, GET works in an expected manner.

Thanks

On Mon, May 26, 2014 at 3:32 PM, David Pilato da...@pilato.fr wrote:

Are you sure you are not using any routing value when indexing?

If so, could you recreate a curl/Sense recreation which reproduce the
problem?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 26 mai 2014 à 15:30:43, Pir Abdul Rasool Qureshi (p...@colourbox.com)
a écrit:

{
"OurIndex": {
"mappings": {
"OurType": {
"properties": {
"added": {
"type": "date",
"format": "dateOptionalTime"
},
"adult_content": {
"type": "boolean"
},
"bucket_id": {
"type": "short"
},
"company_id": {
"type": "long"
},
"created": {
"type": "date",
"format": "dateOptionalTime"
},
"da_keywords_1": {
"type": "string"
},
"da_keywords_2": {
"type": "string"
},
"da_keywords_3": {
"type": "string"
},
"da_keywords_4": {
"type": "string"
},
"da_keywords_5": {
"type": "string"
},
"da_text_keywords_1": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_2": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_3": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_4": {
"type": "string",
"analyzer": "danish"
},
"da_text_keywords_5": {
"type": "string",
"analyzer": "danish"
},
"da_text_title": {
"type": "string",
"analyzer": "danish"
},
"da_title": {
"type": "string"
},
"de_keywords_1": {
"type": "string"
},
"de_keywords_2": {
"type": "string"
},
"de_keywords_3": {
"type": "string"
},
"de_keywords_4": {
"type": "string"
},
"de_keywords_5": {
"type": "string"
},
"de_text_keywords_1": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_2": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_3": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_4": {
"type": "string",
"analyzer": "german"
},
"de_text_keywords_5": {
"type": "string",
"analyzer": "german"
},
"de_text_title": {
"type": "string",
"analyzer": "german"
},
"de_title": {
"type": "string"
},
"dimension": {
"type": "string"
},
"duration": {
"type": "integer"
},
"editorial": {
"type": "string"
},
"en_keywords_1": {
"type": "string"
},
"en_keywords_2": {
"type": "string"
},
"en_keywords_3": {
"type": "string"
},
"en_keywords_4": {
"type": "string"
},
"en_keywords_5": {
"type": "string"
},
"en_text_keywords_1": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_2": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_3": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_4": {
"type": "string",
"analyzer": "english"
},
"en_text_keywords_5": {
"type": "string",
"analyzer": "english"
},
"en_text_title": {
"type": "string",
"analyzer": "english"
},
"en_title": {
"type": "string"
},
"folder_ids": {
"type": "long"
},
"height": {
"type": "integer"
},
"id": {
"type": "string"
},
"f_id": {
"type": "long"
},
"media_type": {
"type": "string"
},
"orientation": {
"type": "string"
},
"published": {
"type": "date",
"format": "dateOptionalTime"
},
"resolution": {
"type": "string"
},
"status": {
"type": "string"
},
"supplier_id": {
"type": "long"
},
"db_id": {
"type": "long"
},
"width": {
"type": "integer"
}

...

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/360f09ba-8dd3-43e1-981f-9b36638a2726%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Neil Andrassy) #19

Hi,

I have a feeling we're facing a similar issue (about which I posted
separately). The behaviour is like the routing that applied before (in our
case explicit on some indexes and just on _id for others) when the document
was indexed, doesn't now resolve to the same shard following a cluster
upgrade from 1.1.1 to 1.2. The data didn't change, only the ES version and
the configuration is automatically deployed so I don't believe that can be
the issue either.

I hope to be able to find time to reproduce the issue on a smaller scale
but it's painful as it involves ES software upgrade.

Neil

On Monday, 26 May 2014 08:47:41 UTC+1, Pir Abdul Rasool Qureshi wrote:

Hi

We have a single machine elastic search server (8 shards but all hosted at
the same machine). Index contains 7 million documents. We do not specify
any custom routing when indexing the documents. We are using Elastic search
version 1.2.

The problem is that we are unable to retrieve many of our documents using GET
, . However using search?_id: we are able to retrieve all
of those documents.

We are also successful in retrieving a document by specifying routing
parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that
problem.

Any suggestions for resolution?

Thanks in advance

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/109aefe5-8074-499f-a7f3-88c6254b1b85%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Neil Andrassy) #20

Looks like this might be a bug in 1.2 -

On Monday, 26 May 2014 08:47:41 UTC+1, Pir Abdul Rasool Qureshi wrote:

Hi

We have a single machine elastic search server (8 shards but all hosted at
the same machine). Index contains 7 million documents. We do not specify
any custom routing when indexing the documents. We are using Elastic search
version 1.2.

The problem is that we are unable to retrieve many of our documents using GET
, . However using search?_id: we are able to retrieve all
of those documents.

We are also successful in retrieving a document by specifying routing
parameter (with different values (1,2,3,...) ) with GET.

With previous version, i.e. Elastic Search 1.0.3, we did not have that
problem.

Any suggestions for resolution?

Thanks in advance

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5f64de11-d918-4120-a899-0a5daf44df4e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.