Documents are not visible and searchable in workplace search


I connected dropbox with workplace search, Drobox id is of Business Type.It contains currently 7 docs,
While connecting dropbox with workplace search, I disabled document level permission so that all docs will be visible to user.

Dropbox successfully connected with workplace search but docs are still showing 0 instead of 7 and still not searchable.

Any suggestions /help will be highly appreciable.

Thank you in advance.

P.s I checked with enabling document level permission to check docs are visible, after connecting to workplace search I am getting a count of 7 docs in worksplace search.

Hey @Divyank_Mahalle,

What version of Enterprise Search are you running? Also, on the content source summary page, does it show syncs having successfully completed? Finally, anything interesting in the content source diagnostics: Troubleshooting errors during content source sync | Workplace Search Guide [7.15] | Elastic?

You mention you've tried both with and without document permissions enabled. One thing to keep in mind is that the necessary OAuth App settings in Dropbox differ in incompatible ways with relation to document permissions. See Step 7 here: Connecting Dropbox | Workplace Search Guide [7.15] | Elastic.

I hope this helps!


1 Like

Hi Ross,

Success...Btw version is 7.15, No error in sync.

Step 7, I had given team permission and in workplace, I tried connecting with disabling document level permission.

Now I remove team level permission in dropbox developer app and connect it with disabling document level permission.It worked !! Lessons learnt :sweat_smile:

Thanks once again.

1 Like