Does kibana understand package registry via proxy?


Appearantly since 7.14 (fleet = GA) I am required to have internet access for my selfmanaged kibana's to reach some packet registry (or host one myself).

However, I set a proxy in the environment and am still not able to reach it. What is going wrong?
The error:

However from the commandline as the kibana user:

[kibana@aapps1121 ~]$ curl ""
    "name": "system",
    "title": "System",
    "version": "1.1.2",
    "release": "ga",
    "description": "This Elastic integration collects logs and metrics from your servers",
    "type": "integration",
    "download": "/epr/system/",
    "path": "/package/system/1.1.2",
    "icons": [
        "src": "/img/system.svg",
        "path": "/package/system/1.1.2/img/system.svg",
        "title": "system",
        "size": "1000x1000",
        "type": "image/svg+xml"
    "policy_templates": [
        "name": "system",
        "title": "System logs and metrics",
        "description": "Collect logs and metrics from System instances"
][kibana@aapps1121 ~]$

I am running as kibana user:

[kibana@aapps1121 ~]$ ps -ef|grep kibana
kibana    62605      1  0 16:13 ?        00:00:00 /usr/share/kibana/bin/../node/bin/node /usr/share/kibana/bin/../src/cli/dist --logging.dest="/var/log/kibana/kibana.log" --pid.file="/run/kibana/"
kibana    62617  62605  4 16:13 ?        00:00:37 /usr/share/kibana/node/bin/node --preserve-symlinks-main --preserve-symlinks /usr/share/kibana/src/cli/dist --logging.dest="/var/log/kibana/kibana.log" --pid.file="/run/kibana/"

Solved by adding
xpack.fleet.registryProxyUrl: "http://proxy-url:8080" to kibana.yml

I find it bad practice that kibana does not make use of regular environment variables.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.