"-Dproperty.name" settings from command line are ignored


(fucema) #1

Opened a new issue for ignored settings used in command line startup.

I have verified that setting -Dcluster.name and -Dnetwork.host works properly in version 0.11.0 but are ignored in version 0.12.1

Here is the link to the issue: https://github.com/elasticsearch/elasticsearch/issues/issue/475


(Shay Banon) #2

Hi,

You need to prefix the system property with es, for example: -
Des.cluster.name. This is how it works both in 0.11 and in 0.12. Not sure
how it works for you in 0.11 (without the es. prefix)... (checked, it
doesn't).

-shay.banon

On Wed, Nov 3, 2010 at 7:14 PM, fucema fucema@gmail.com wrote:

Opened a new issue for ignored settings used in command line startup.

I have verified that setting -Dcluster.name and -Dnetwork.host works
properly in version 0.11.0 but are ignored in version 0.12.1

Here is the link to the issue:
https://github.com/elasticsearch/elasticsearch/issues/issue/475

View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/Dproperty-name-settings-from-command-line-are-ignored-tp1836278p1836278.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.


(system) #3