Dropdown for selecting Timelion Interval in Dashboard

(Azham N) #1

Hi,

I have some Timelions in a dashboard. When creating the timelions I set the interval to auto so that it can scale according to the time range selected in the dashboard. When viewing the dashboard I would like to be able to select the interval (similar to how the time range is selected) so I can change the resolutions without having to edit each visualization.

Is this supported at present? If not how can I go about implementing this? Any leads?

Thanks.

(Joe Fleming) #2

You're not crazy, it's just not something you can do from dashboard interface. I don't know if the team responsible is planning to implement that control in the dashboard panels, and I can't find anything related to it in the Kibana issue tracker. You're welcome to open a feature request there and hopefully get some feedback from the team that works on the dashboard functionality.

(Azham N) #3

The reason behind such a requirement is due to the default behaviour of the 'auto' setting for the interval. When set to auto it seems that it tries to default to the smallest unit possible (i.e: 1s). This is not ideal in a situation where we select a small time range. For example (15 min range):


The interval has been set to auto which in this case equals to 1s. For this time range this is not very readable.

However in contrast:


If we set the interval to 1m, it makes it so much more readable and hence useful.

So the ability to change this on the fly would be great. As suggested I will create a new issue for this. In the meanwhile, could please explain the interval selection logic for auto? I'm assuming it is relative to the time range selected? Pointing towards the source code for this logic would also be great!

Thanks.

(Joe Fleming) #4

I think this is all calculated here: https://github.com/elastic/kibana/blob/master/src/legacy/core_plugins/timelion/common/lib/calculate_interval.js

But I'm not really sure how it's being used so I'm having a hard time understanding how it works. I can see that when you set the value to auto it just uses the interval that is passed in, but I'm having a hard time tracing this back to figure out what value(s) end up in there.

(system) closed #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.