ECE + AWS load balancer: port configuration?

I have a load balancer in front of ECE to front the cluster URLs for kibana and elasticsearch. These all use port 9243 and the config in the ECE UI allows me to set a CNAME to be used instead of the ip.es.io service... This works and I can use the CloudID to configure beats etc.

So far so good. But I would like to present the services not only on the domain of my choosing but move the port to a standard one - eg. 443, which would allow me to use the service through a corporate web proxy.

I configure the load balancer to listen on 443 and target 9243.

I can add the port assignment to the endpoint configuration / CNAME and it is accepted and the resulting CloudID seems right. But none of the links in the ECE UI work then. I suspect this is a bug. (I can manually make a CloudID including the port 443 using base64 that works with beats.)

So far the least broken approach is to configure the endpoint without port, the links in ECE point to xxx:9243 which doesn't get through the proxy, but removing the :9243 then makes the link work. The manually modified CloudID also works to get beats to access elasticsearch over port 443.

Is there any way to configure ECE to build URLs and CloudID with a specific port in addition to the specific endpoint?

I believe this API call will work:

curl -k -X POST -u admin:xxxxxxxxx https://{ADMIN_SERVER}:12443/api/v1/platform/configuration/store/https_port -H 'Content-Type: application/json' -d '
{
   "value" : "443"
}

Alex,

thanks for the hint - that's an awesome fix.

I had to change POST to PUT because "Config option [https_port] already exists" but it seems to work nicely.