ECE - Unable to use base_path in snapshot repository configuration

When attempting to configure an S3 snapshot repository in ECE I'm unable to specify a base_path like:

    "type": "s3",
    "settings": {
        "bucket": "backups",
        "base_path": "ece"

When attempting this with an IAM role configured to only allow access to the ece directory it fails with the following error:

Unexpected error during step: [ensure-repository]: [
java.lang.Exception: Unable to ensure existence of snapshot repository: [
HttpResponse(500 Internal Server Error, HttpEntity(application/json; charset=UTF-8,
                "reason":"[found-snapshots] path [snapshots/00000000000000000000000000000000] is not accessible on master node"
        "reason":"[found-snapshots] path [snapshots/00000000000000000000000000000000] is not accessible on master node",
            "reason":"Unable to upload object [snapshots/00000000000000000000000000000000/tests-0000000000000000000000/master.dat-temp] usi...),List(Warning: 299 Elasticsearch-5.6.5-6a37571 "[repositories.s3.buffer_size] setting was deprecated in Elasticsearch and will be removed in a future release! See the breaking changes documentation for the next major version." "Thu, 18 Jan 2018 00:00:00 GMT", Content-Type: application/json; charset=UTF-8, Content-Length: 800),HTTP/1.1)

When giving the ECE instances full access to the bucket, everything works, but the snapshots end up in snapshots/, not ece/snapshots/.

This is the output of _snapshot of the cluster itself:


Is this just not supported in ECE yet?

Yes, you can narrow down the permissions with an IAM Role. Please refer to this

I originally followed those exact steps and got the errors I listed above when attempting to place the snapshots in a directory.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.