Elastic 6.3.0 Error installing discovery and repository plugins


(Praetor) #1

Hello,
We've been successfully been able to install discovery 5.5 and 6.2.4 plugins on their respective Elastic Versions. We're using CFTs to install ES and these respective plugins. However, we moved to install 6.3.0 today and only had to make the changes to use the 6.3.0 versions of these artifacts - and almost everything went fine except for the installation of the plugins.

Installation logs in EC2 indicate this. Installing the 6.2.4 versions immediately to on a different stack produces no such problems. I downloaded all the artifacts from elastic.io download locations. It's odd why the 6.2.4 would go through seamlessly however 6.3.0 suddenly gives this. Can anyone help? Nothing else has changed in the CFT except the move to 6.3.0 from both 5.5.2 or 6.2.4!

Exception in thread "main" java.lang.IllegalStateException: unable to read from standard input; is standard input open and a tty attached?
at org.elasticsearch.cli.Terminal$SystemTerminal.readText(Terminal.java:168)
at org.elasticsearch.plugins.PluginSecurity.prompt(PluginSecurity.java:74) ] 37% ^M[==================> ] 38% ^M[==================>
at org.elasticsearch.plugins.PluginSecurity.confirmPolicyExceptions(PluginSecurity.java:67)==========> ] 41% ^M[====================>
]at org.elasticsearch.plugins.InstallPluginCommand.installPlugin(InstallPluginCommand.java:726) ] 44% ^M[=====================> ] 45% ^M[==at org.elasticsearch.plugins.InstallPluginCommand.install(InstallPluginCommand.java:641) ] 47% ^M[=======================> ] 48% ^M[==============at org.elasticsearch.plugins.InstallPluginCommand.execute(InstallPluginCommand.java:225) ] 50% ^M[========================> ] 51% ^M[=========================>at org.elasticsearch.plugins.InstallPluginCommand.execute(InstallPluginCommand.java:210) ^M[==========================> ] 54% ^M[==========================>
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)====================> ] 57% ^M[============================>
]at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)========================> ] 60% ^M[=============================> ] 61% ^M[==at org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:79)=====================> ] 63% ^M[===============================> ] 64% ^M[==============at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)===> ] 66% ^M[================================> ] 67% ^M[==========================at org.elasticsearch.cli.Command.main(Command.java:90)=============> ] 69% ^M[==================================> ] 70% ^M[==================================> at org.elasticsearch.plugins.PluginCli.main(PluginCli.java:48) ] 72% ^M[===================================>


(David Pilato) #2

You probably need to use this option https://www.elastic.co/guide/en/elasticsearch/plugins/current/_other_command_line_parameters.html#_batch_mode


(Praetor) #3

thats the first thing i tried. though i didn't even need to do this in 6.2.4 or 5.5.2. Here's the wierd thing. If i try to run the same install command (with or without batch) later independently on the same EC2 it works fine. Its just not working as part of EC2 user data boot strapping in 6.3.0.
Then again- all ive done is switched from 6.2.4 to 6.3.0 and 6.2.4 never complained about this in user-data bootstrapping.


(David Pilato) #4

I don't know what is "CFT".
Only thing I know is that I came to the same issue yesterday with Docker. And came to write this documentation PR:


(Praetor) #5

CFTs are Cloud Formation TEmplates (AWS).


(David Pilato) #6

Can you share your template then? The one with --batch option?


(Praetor) #7

"sudo /usr/share/elasticsearch/bin/elasticsearch-plugin install file:///repository-s3-6.2.4.zip --batch"

Is the position of the --batch the probably cause here?


(David Pilato) #8

Yes. I found that putting it at the wrong place does not work.


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.