Cant seem to install plugin with elasticsearch

HI ,

I am having issues with Elasticsearch-plugin command or maybe elasticsearch in general. I have tried countless ways and can't seem to find out the issue.

when I install the plugin ./elasticsearch-plugin install repository-s3 using the plugin manager the connection hangs and doesn't finish.

I also made sure http and https was open...still no results.

I also used the offline download using the file and I get this error:

-> Downloading file:/usr/share/elasticsearch/plugins/
[=================================================] 100%   
-> Failed installing file:/usr/share/elasticsearch/plugins/
-> Rolling back file:/usr/share/elasticsearch/plugins/
-> Rolled back file:/usr/share/elasticsearch/plugins/
Exception in thread "main" java.nio.file.NoSuchFileException: /usr/share/elasticsearch/plugins/.installing-14653170667895787521/
	at java.base/sun.nio.fs.UnixException.translateToIOException(
	at java.base/sun.nio.fs.UnixException.rethrowAsIOException(
	at java.base/sun.nio.fs.UnixException.rethrowAsIOException(
	at java.base/sun.nio.fs.UnixFileSystemProvider.newByteChannel(
	at java.base/java.nio.file.Files.newByteChannel(
	at java.base/java.nio.file.Files.newByteChannel(
	at java.base/java.nio.file.spi.FileSystemProvider.newInputStream(
	at java.base/java.nio.file.Files.newInputStream(
	at org.elasticsearch.plugins.PluginInfo.readFromProperties(
	at org.elasticsearch.plugins.InstallPluginCommand.loadPluginInfo(
	at org.elasticsearch.plugins.InstallPluginCommand.installPlugin(
	at org.elasticsearch.plugins.InstallPluginCommand.execute(
	at org.elasticsearch.plugins.InstallPluginCommand.execute(
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(
	at org.elasticsearch.cli.MultiCommand.execute(
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(
	at org.elasticsearch.cli.Command.main(
	at org.elasticsearch.plugins.PluginCli.main(

I would appreciate some help.

The installation complains that the file cannot be found. This means the plugin artefact (zip file) is corrupted or not correctly packaged. I suspect that you were not installing the plugin from the official repository.

This line shows that the plugin was installed from a local file instead of the official repo. You can either install from the official repo or download for offline installation as documented.

Hello @cctk

You might try to use Batch mode, like this: ./elasticsearch-plugin install --batch repository-s3

For more information you can click here , here and here

Let me know the result.

Hello @cctk ,

How are you?

I'm following up just to know if the information shared solved the issue.


I have not tried it properly yet however, I did try the --batch command already but nothing worked.

Did you get the same error after adding - - batch to the command?

sorted the issue. It was actually easier than I made it out to be.
ran the following.
./elasticsearch-plugins install

thank you

1 Like

Thanks for sharing the solution

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.