Elastic-Agent - Non-zero metrics in the last 30s

Running 8.1.2, is there a way to disable the metrics logging of this within the Elastic-Agent ?

This without disabling "Collect Agent Logs"... I want the logs but not the metrics logging.

You normally could do this within Beats, e.g. Metricbeat.yml

# If enabled, Metricbeat periodically logs its internal metrics that have changed
# in the last period. For each metric that changed, the delta from the value at
# the beginning of the period is logged. Also, the total values for
# all non-zero internal metrics are logged on shutdown. The default is true.
logging.metrics.enabled: false

Ideally to get rid of log pollution without having to filter out.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

Based on Beats and Elastic Agent capabilities | Fleet and Elastic Agent Guide [8.4] | Elastic the logging configurations are supported by the agent so the settings can be used to turn these log lines off if that's what you'd like to do.

Please note that since Agent encompasses different integrations , these settings may or may not be applicable and I believe this is why it's not at the policy level but at the integration level.
You can add them in the advanced configurations for the specific integration you are adding to the Policy and depending on the integration itself and if you use the available defaults you may need to look a bit under the hood to see the section for these type of settings.

I hope below 2 screenshots prove helpful.