Elastic agent upgrade 8.7.1 failed

Hello ,When I upgraded the elastic agent from 8.5.2 to 8.7.1, the following error occurred, and I have been unable to upgrade to 8.7.1. What is the solution?

message: "component gateway-8da30c24: failed to dispatch actions, error: failed upgrade
  of agent binary: 2 errors occurred:\n\t* package '/Library/Elastic/Agent/data/elastic-agent-c13f91/downloads/elastic-agent-8.7.1-darwin-x86_64.tar.gz'
  not found: open /Library/Elastic/Agent/data/elastic-agent-c13f91/downloads/elastic-agent-8.7.1-darwin-x86_64.tar.gz:
  no such file or directory\n\t* copying fetched package failed: net/http: request
  canceled (Client.Timeout or context cancellation while reading body)\n\n"

Have you retried this upgrade and received the same error? It seems the download of the 8.7.1 Agent failed. How is the internet connection from the machine with the Agent running?

The retry is still the same, the proxy local network is normal, and there is no problem visiting other websites to download, but visiting https://artifacts.elastic.co feels slow. Is there any way to improve this? Or can there be a way to have multiple download addresses for backup, and then the download speed can be accelerated?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.