Elastic Cloud - This might not be the site you want

I am using latest Microsoft Edge browser and every time I access Kibana on Elastic Cloud I get warning about suspicious site. I have 2 clusters in Azure West Europe.

Url: https://xxx.kb.westeurope.azure.elastic-cloud.com:0000

Is there something you can do about? Like talking to Microsoft?

BTW I do not have any problem with Kibana just the browser warning is annoying.

I @milesich Welcome the community and thanks for using Elastic Cloud.

I will pass this on, but first one question can you try the URL without any port? you have :0000 not sure if that is a typo valid is :9243 or :443 or none (preferable)

And can you include a screen shot please :slight_smile:

I removed the port intentionally from the example because I thought it could be different per setup :slight_smile:

I don't get the warning without the port. I didn't know that was an option since all mentions of Kibana url in cloud console contains :9243.

Also since I accessed the URL without the port I no longer get the warning with the port so not sure what is going on :confused:. When I see it again I will post screen shot.

1 Like

Yes that is historical... I wish we would change the docs.. all endpoints support default :443 i.e. no port needed.

Ahhh the nature of tech :slight_smile:

Warning is back @stephenb

@milesich

Couple questions from the Cloud Ops folks

Are you using a proxy?

Can you confirm the details on the cert .should be issued by LetsEncrypt and have serial number 04 19 60 5D 6D DE 82 9B E6 DE 6F CD 23 8D 44 46 ED 36

(this is viewable from the browser on their end if they view details...usually its when you right click on the lock icon in the address bar)

Also can you click the report as safe button in that message?

Hi @stephenb

I am not using a proxy. I have direct residential connection to the ISP.

I have reported the site as safe multiple times in the past and the serial number looks the same.

This is new as of today:

Screenshot 2022-06-05 at 08.22.06-clean

I did some testing and the login and space selector pages does not even show a warning, they are completely fine.

https://xxx.kb.westeurope.azure.elastic-cloud.com:9243/login?next=%2F
https://xxx.kb.westeurope.azure.elastic-cloud.com:9243/spaces/space_selector

For everything after choosing space I get the red unsafe page. In this case the port does not play any role. It is the same for :9243 and :443. FYI this is Kibana v8.2.2.

Thanks I'll pass this on..

And can you open a support ticket and include this information?

Ticket created.

Hmmm I could not reproduce.

Microsoft Edge
Version 102.0.1245.33 (Official build) (64-bit)

Same region Azure
Created a couple Spaces
Tried with and without the ports
I even Turned up Edge to Max Security from Balanced
I am not seeing yet... curious what you find out.

Microsoft Edge
Version 102.0.1245.33 (Official build) (x86_64)
macOS Monterey 12.3.1

I think it is going to be hard to reproduce because it is not consistent for me either. Like /s/default/app/home#/ was ok but /app/home#/ was dangerous on the same domain. I restarted the browser now and it is not dangerous at all currently.

You're running Edge on Mac OS?
Interesting. I didn't even know you could do that.

Keep an eye...

I let our cloud ops folks know they're keeping an eye too.