Elastic RUM JS agent not tracking client IP address

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight_smile:

Kibana version: 7.4.0

Elasticsearch version:7.4.0

APM Server version:7.4.0

APM Agent language and version: apm-rum-angular: 0.3.0

Browser version: Chrome 78

Original install method (e.g. download page, yum, deb, from source, etc.) and version:

Fresh install or upgraded from other version?

Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):

I remember elastic RUM JS agent was tracking the client IP address before and I was able to see it in kibana and filter by it. I am no longer able to see that information. Is there something I need to enable for that to show up?

Hi Kartheek,

RUM agent never tracked the client ip, It was possible through the GeoIp pipeline processor of the APM server https://www.elastic.co/guide/en/apm/server/current/configuring-ingest-node.html

Since 7.4 the pipeline is enabled by default. Also, do you see any error on the server logs?

Could you please share your APM server config?


@vigneshshanmugam ok I understand now. I can see that I can filter by host.ip or client.ip. So it was always enabled for me.

I was using kibana 6.6.0 before which had a different name to filter by and also displayed the IP address as part of the metadata view. Is it possible to display the IP address in the metadata tab with the 7.4.0 version? I dont see it by default anymore.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.