Elastic Search Failure over EC2 AWS

I was trying to install Magento over Amazon EC2 instance and it requires ElasticSearch as prerequisite. I followed available methods to install it through Archive and the other method. But none of them worked for me.

When I run "sudo service elasticsearch start", it fails and the snapshot of "journalctl -xe" is attached. Can someone help me what is wrong here and what is my mistake. It is currently installed in /etc/share/elasticsearch. I also reduced to half the memory in java.options file due to few errors in start.

Welcome to our community! :smiley:

Please don't post pictures of text, they are difficult to read, impossible to search and replicate (if it's code), and some people may not be even able to see them.

Log clearly says access denied /var/run/elasticsearch.

Check permission on this directory. Should be writable to the user running elasticsearch process.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.