Elastic search is not starting

root@:/# service elasticsearch start

Starting Elasticsearch Server [ OK ]
root@:/# service elasticsearch status
elasticsearch is not running
this is the issue i am facing. earlier port 9200 is to be in close wait state. i thought closing it forcely will resolve my issue. But, it did not solve my issue.

can you tell me what message displays in command prompt when you typed "service elasticsearch status" command

root@:/# service elasticsearch status
elasticsearch is not running

can you take screenshot and upload it


Is there anything of interest in the Elasticsearch logs?

there are no recent logs

What do you see in the logs if you restart the service?

once you have to restart your system..
then type this command "netstat -nlp|grep 9200" if port is in use then kill it by this command
"kill -9 pid" (pid means u will seen one id by typing previous command).
After killing the port then u have to start elastic search.

i already killed the port which is in close_wait state

there are no logs. only two logs of the previous dates are present.
I had this problem right from the begining of the installation. after restrating multiple times. the problem got resolved. But my server went down for 3 days. after the server is up the same problem arised.

you can kill that close_wait state connection also then try it

this is the output

have you set all configurations, and check port in configuration file

Are you sure there is nothing in the Elasticsearch logs? The location depends on how you installed Elasticsearch, but should be /var/log/elasticsearch if you installed it using a package.


What is in elasticsearch.log? Please copy and paste (with formatting) rather than paste images of text.

it is running fine in the virtual box.. but in the vps it is creating the issue. but after some multiple restarts it worked fine. but the vps denied acceess for 3 days . after 3 days.. it started responding.. but showing same error. i restarted multipe times and killed the port which is in time wait state....and restarted the service again but the problem didnt solved.

[2018-03-16 02:05:21,536][WARN ][monitor.jvm ] [Ms. Steed] [gc][you ng][16111][23] duration [2.5d], collections [1]/[2.5d], total [2.5d]/[2.5d], mem ory [117.6mb]->[51.6mb]/[1015.6mb], all_pools {[young] [65.9mb]->[296.7kb]/[66.5 mb]}{[survivor] [3.6mb]->[3.3mb]/[8.3mb]}{[old] [48mb]->[48mb]/[940.8mb]}