ElasticSearch service shows "active running" but it's not listening on port 9200, and no logs are being written


#1

Ubuntu 16.04 with Elasticsearch 6.2.1 on a VM in Azure - a couple days ago I could not get the ElasticSearch service to start at all. I resolved the issue with help from a kind soul by increasing the heap size in the jvm.options file. ( I still don't understand though why the service worked before and then suddenly stopped until I made that heap adjustment.

But's moot at this point:

Now I have the ElasticSearch service running - when I run systemctl status elasticsearch, it shows "Active (running), but I cannot ping the service on port 9200 at all I'm using Postman and just receive the messageCould Not Get Any Reponse I have now confirmed via the command netstat -nultp | grep 9200 that port 9200 is not listening (I get no response when I run that command)

The part that is making this impossible to diagnose is nothing is getting written to the ElasticSearch logs! The last time anything was written to any log at /var/log/elasticsearch was over 2 days ago, and I've been starting, stopping and restarting the ES service many times over the last 2 days but no logging at all!

We have another ES Linux box where everything is working fine: I have compared the settings in that elasticsearch.yml with the elasticsearch.yml file that's on this box and other than a couple entries related to additional nodes in the working one, the two files' settings match. I'm at a loss and we're at a standstill.

Does anyone have any suggestions on how to get ES to listen on port 9200 and why there is no logging at all being written if the service is running?

Thanks.


#2

The issue has been resolved. There was an extraneous quotation mark in the elasticsearch.yml which caused the entire service to fail.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.