Elastic Search / Kibana / Logstash -

Hi, I have set up a test environment running on Windows 7 and aftr following all the various information I can find it looks to be correct working as individual components but not together.

logstash 1.1.9
ES - I have tried 0.19.2, 0.20.2, 0.20.4
Kibana - 0.2.0

I have logstash processing source logs, indexing and sending to ES. Ocassionally (though seems quirky) the logstash web gui can search the logs by connecting to ES.

However when I run up Kibana, and then try and browse to it, ES throws an error, the first part of the stack trace is shown. I have tried all versions listed above of ES, and all present the same error.

Can anyone assist at all in what the error is / means ? Any assistance much appreciated as I've spent a lot of time googling and trying various configurations (even one suggesting try the machine IP rather than local loopback for listening on - which I've done for all components).

Many thanks.

[2013-01-30 12:56:53,528][WARN ][transport.netty ] [Beechman, Jerome] exception caught on transport layer [[id:
0xe2c4c67c, / => /]], closing connection
java.io.StreamCorruptedException: invalid internal transport message format
at org.elasticsearch.transport.netty.SizeHeaderFrameDecoder.decode(SizeHeaderFrameDecoder.java:27)
at org.elasticsearch.common.netty.handler.codec.frame.FrameDecoder.callDecode(FrameDecoder.java:425)
at org.elasticsearch.common.netty.handler.codec.frame.FrameDecoder.messageReceived(FrameDecoder.java:303)
at org.elasticsearch.common.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandl
at org.elasticsearch.common.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:560)
at org.elasticsearch.common.netty.channel.DefaultChannelPipeline$DefaultChannelHandlerContext.sendUpstream(Defau