ES 2.0 strange java.io.StreamCorruptedException


#1

When I start ES 2.0 as is extracted from ZIP file on my Windows 7 x64 computer, I get multiple (12x) WARNINGS like following:

[2015-11-12 13:34:08,248][WARN ][transport.netty ] [Lorelei II] exception caught on transport layer [[id: 0xf9e16854, /127.0.0.1:3940 => /127.0.0.1:9300]], closing connection
java.io.StreamCorruptedException: invalid internal transport message format, got (48,54,54,50)
...

After these warnings, starting continues and ES eventually stays running.

I tried this with different Java versions }for example jdk1.7.0_71, jre1.8.0_65 or jdk1.8.0_65] but with exactly the same result.

If I try the same test with ES 1.7.3 ZIP file, no WARNING appears.

I know it is something specific for my PC, for when I tried it on one of our test servers, it worked fine. But I am little bit nervous.

I would like to understand this WARNING before I start with cluster upgrade.

Any idea what is this WARNING about?


(David Pilato) #2

A first guess is that you have another node running using another elasticsearch version which is trying to connect to this node...


(Mark Walkom) #3

I'll second that assessment! :slight_smile:


(Craig Ching) #4

Sorry to jump on the pile, but I'll third it. Just ran into this last night, swore up and down that I had my storm deployment right only to find that I'd been deploying a stale build artifact that included the old 1.7 client for ES :unamused:


#5

I did fresh boot of my system and the only thing I did was that I unzipped original Elasticsearch distribution package and executed elasticearch.bat

Before this, I had checked that no java process was running. Ss you can see from log, communication is within local computer and default configuration of Elasticsearch doesn't allow remote connections anyway.

So I can't imagine what communication is going on :frowning:


(system) #6